[MAAS 2.1.2] Issue with adding routes to hosts via maas

Bug #1649652 reported by Brandon Sawyers
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
MAAS
Invalid
Medium
Unassigned
curtin
Fix Released
Medium
Unassigned
curtin (Ubuntu)
Fix Released
Medium
Unassigned
Xenial
Fix Released
Medium
Unassigned
Yakkety
Fix Released
Medium
Unassigned

Bug Description

==== Begin SRU Template ========
[Impact]
System configuration of networking with static routes did not
work properly. Systems where static routes were necessary would
install but not come up with the desired networking.

[Test Case]
Run curtin vmtest on tests/vmtests/test_network_static_routes.py
These tests show the failure without a patched curtin,
and passing verifies the fix.

[Regression Potential]
Likeliest path to regression would be in failure of other network
configurations.

[Other Info]
==== End SRU Template ========

I'm trying to set routes for a subnet and have them be passed to a host during provision.

This fails due to formatting issues in the /etc/network/interfaces file.

I've attached both /etc/network/interfaces and the output of get-curtin-config. I'm running version 2.1.2+bzr5555-0ubuntu1~16.04.1.

roaksoax suggested this was a curtin issue, but would still be tracked here.

Please let me know if you need anymore information.

Thanks,
Brandon

Related branches

Revision history for this message
Brandon Sawyers (brandor5) wrote :
Revision history for this message
Brandon Sawyers (brandor5) wrote :
Revision history for this message
Brandon Sawyers (brandor5) wrote :
Revision history for this message
Brandon Sawyers (brandor5) wrote :

I doubt that it's the correct fix, but I've attached the change I've made to my local install to get this working again.

Thanks!

Revision history for this message
Scott Moser (smoser) wrote :

Just fyi, something rendered 'network' in the attached config twice. It may be valid yaml but seems wrong.

Changed in maas:
status: New → Confirmed
importance: Undecided → Medium
Changed in curtin:
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Brandon Sawyers (brandor5) wrote :

Scott,

That could have been my fault when copying the text over. I didn't have network connectivity, only the drac console.

Thanks,
Brandon

Gavin Panella (allenap)
Changed in maas:
status: Confirmed → Triaged
Changed in maas:
status: Triaged → Invalid
tags: added: maas
Jon Grimm (jgrimm)
Changed in curtin:
status: Confirmed → In Progress
Scott Moser (smoser)
Changed in curtin:
status: In Progress → Fix Committed
Changed in curtin (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
Changed in curtin (Ubuntu Xenial):
status: New → Confirmed
Scott Moser (smoser)
description: updated
Scott Moser (smoser)
Changed in curtin (Ubuntu Yakkety):
status: New → Confirmed
importance: Undecided → Medium
Changed in curtin (Ubuntu Xenial):
importance: Undecided → Medium
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Brandon, or anyone else affected,

Accepted curtin into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/0.1.0~bzr460-0ubuntu1~16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in curtin (Ubuntu Yakkety):
status: Confirmed → Fix Committed
tags: added: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Brandon, or anyone else affected,

Accepted curtin into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/0.1.0~bzr460-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in curtin (Ubuntu Xenial):
status: Confirmed → Fix Committed
Revision history for this message
Brandon Sawyers (brandor5) wrote :

Thanks for the update Brian.

As soon as I get access back to my test pod I'll give these packages a try and report back here.

Revision history for this message
Danny Hammo (dan-hammo) wrote :

Verified curtin package in xenial-proposed fixes the formatting issue in /etc/network/interfaces when adding static routes through MaaS gui.

dpkg -l | grep curtin
ii curtin-common 0.1.0~bzr460-0ubuntu1~16.04.1 all Library and tools for curtin installer
ii python3-curtin 0.1.0~bzr460-0ubuntu1~16.04.1 all Library and tools for curtin installer

tags: added: verification-done
removed: verification-needed
Scott Moser (smoser)
tags: added: verification-done-xenial verification-needed-yakkety
removed: verification-done
Revision history for this message
Scott Moser (smoser) wrote :

I've run curtin's vmtest testsuite on a test added to show this bug
 tests/vmtests/test_network_static_routes.py
Additionally, there were unit tests added that run during package
build.

Ran curtin vmtest like:

# get curtin for it tests at revision 460
$ bzr branch lp:curtin curtin.dist
$ bzr branch -r 460 curtin.dist curtin-r460
$ cd curtin-r460
## need to get 'curtainer' and 'curtin-in-container' from trunk
$ cp ../trunk.dist/tools/{curtainer,curtin-from-container} tools/
$ ./tools/vmtest-system-setup
$ ./tools/curtainer --proposed ubuntu-daily:yakkety sm-curtin-y1
Setting up curtin-common (0.1.0~bzr460-0ubuntu1~16.10.1) ...
Setting up python3-curtin (0.1.0~bzr460-0ubuntu1~16.10.1) ...
Setting up curtin (0.1.0~bzr460-0ubuntu1~16.10.1) ...

# bug 1649652 tests/vmtests/test_network_static_routes.py
$ name=sm-curtin-y1
$ CURTIN_VMTEST_TOPDIR=$PWD/$name CURTIN_VMTEST_CURTIN_EXE="./tools/curtin-from-container $name curtin" \
   ./tools/jenkins-runner tests/vmtests/test_network_static_routes.py

Note, due to packaging bug 1666986, we see in the installation logs:
   curtin: Installation started. (0.1.0)
when that is fixed, we'll start seeing 0.1.0~bzr460-0ubuntu1~16.10.1.

tags: added: verification-done-yakkety
removed: verification-needed-yakkety
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 0.1.0~bzr460-0ubuntu1~16.10.1

---------------
curtin (0.1.0~bzr460-0ubuntu1~16.10.1) yakkety-proposed; urgency=medium

  * New upstream snapshot.
    - Install zipl in target on s390x arch. (LP: #1662346)
    - avoid UnicodeDecode error on passing non-utf8 into shlex
    - adjustments to version string handling, improved pack unit tests.
    - helpers/common: Add grub install debugging output
    - curtin: add version module and display in output and logs
    - content decoding in load_file, apply_net raise exception on errors
    - gpg: retry when recv'ing gpg keys fail (LP: #1661337)
    - Add clear_holders checks to disk and partition handlers (LP: #1659509)
    - net: add new lines after rendered static routes. (LP: #1649652)
    - multipath: don't run update-grub; setup_grub will handle this better.
      (LP: #1656369)
    - Test changes:
      - vmtest: Add tests for zesty and Trusty HWE-X kernels.
      - tests: fix tox tip-pycodestyle complaints
      - image-sync: add debugging output to help diagnose errors
      - vmtest: change get_curtin_version to use version subcommand.
      - Remove style checking during build and add latest style checks to tox
      - subp doc an unit test improvements.
      - flake8: remove unused variable.
      - vmtest: Add the ability to add extra config files to test execution.
      - vmtest: overhaul image sync
      - vmtest: skip apt-proxy test if not set
      - vmtest: add 'webserv' helper
      - vmtest: add CURTIN_VMTEST_CURTIN_EXE variable.

 -- Scott Moser <email address hidden> Thu, 16 Feb 2017 22:30:13 -0500

Changed in curtin (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of the Stable Release Update for curtin has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 0.1.0~bzr460-0ubuntu1~16.04.1

---------------
curtin (0.1.0~bzr460-0ubuntu1~16.04.1) xenial-proposed; urgency=medium

  * New upstream snapshot.
    - Install zipl in target on s390x arch. (LP: #1662346)
    - avoid UnicodeDecode error on passing non-utf8 into shlex
    - adjustments to version string handling, improved pack unit tests.
    - helpers/common: Add grub install debugging output
    - curtin: add version module and display in output and logs
    - content decoding in load_file, apply_net raise exception on errors
    - gpg: retry when recv'ing gpg keys fail (LP: #1661337)
    - Add clear_holders checks to disk and partition handlers (LP: #1659509)
    - net: add new lines after rendered static routes. (LP: #1649652)
    - multipath: don't run update-grub; setup_grub will handle this better.
      (LP: #1656369)
    - Test changes:
      - vmtest: Add tests for zesty and Trusty HWE-X kernels.
      - tests: fix tox tip-pycodestyle complaints
      - image-sync: add debugging output to help diagnose errors
      - vmtest: change get_curtin_version to use version subcommand.
      - Remove style checking during build and add latest style checks to tox
      - subp doc an unit test improvements.
      - flake8: remove unused variable.
      - vmtest: Add the ability to add extra config files to test execution.
      - vmtest: overhaul image sync
      - vmtest: skip apt-proxy test if not set
      - vmtest: add 'webserv' helper
      - vmtest: add CURTIN_VMTEST_CURTIN_EXE variable.

 -- Scott Moser <email address hidden> Wed, 08 Feb 2017 19:40:38 -0500

Changed in curtin (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Scott Moser (smoser) wrote : Fixed in Curtin 17.1

This bug is believed to be fixed in curtin in 17.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers