[2.1] rsyslog is flooded with "no link-local IPv6 address for $IFACE" on commissioning

Bug #1640147 reported by Nobuto Murata on 2016-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Low
LaMont Jones
2.1
Undecided
LaMont Jones
isc-dhcp (Ubuntu)
Undecided
Unassigned

Bug Description

When commissioning, /var/log/maas/rsyslog/ is flooded with the repeated messages below with over 30,000 lines.

====
Nov 8 11:57:54 bunyip dhclient[4734]: no link-local IPv6 address for enp4s0f0
Nov 8 11:57:54 bunyip dhclient[4734]:
Nov 8 11:57:54 bunyip dhclient[4734]: If you think you have received this message due to a bug rather
Nov 8 11:57:54 bunyip dhclient[4734]: than a configuration issue please read the section on submitting
Nov 8 11:57:54 bunyip dhclient[4734]: bugs on either our web page at www.isc.org or in the README file
Nov 8 11:57:54 bunyip dhclient[4734]: before submitting a bug. These pages explain the proper
Nov 8 11:57:54 bunyip dhclient[4734]: process and the information we find helpful for debugging..
Nov 8 11:57:54 bunyip dhclient[4734]:
Nov 8 11:57:54 bunyip dhclient[4734]: exiting.
====

$ wc -l /var/log/maas/rsyslog/bunyip/2016-11-08/messages
39278 /var/log/maas/rsyslog/bunyip/2016-11-08/messages

It would be nice to suppress those lines if those could be safely ignored. It would make troubleshooting easier when something wrong happened on commissioning.

Related branches

Nobuto Murata (nobuto) wrote :
Changed in maas:
importance: Undecided → Low
milestone: none → 2.2.0
status: New → Triaged
LaMont Jones (lamont) wrote :

tl;dr: dhclient -6 should be less spam-chatty in the presence of no ipv6 support.

If dhclient logged that as one message, instead of 9 messages, then syslog would compress the output.

The easiest way that I've seen to reproduce this is to boot with ipv6.disable=true on the kernel command line.

Nobuto: do you have ipv6 disabled via the kernel command line? (This is known to cause various issues for a number of daemons.)

LaMont Jones (lamont) wrote :

The loop of output is caused by maas trying to get an ipv6 address in a loop, even though the interface clearly does not support ipv6. (If it did, there would be a link-local address.)

Changed in isc-dhcp (Ubuntu):
status: New → Invalid
LaMont Jones (lamont) on 2017-02-14
Changed in maas:
assignee: nobody → LaMont Jones (lamont)
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
Mike Pontillo (mpontillo) wrote :

I'm still seeing this on trunk.

Mar 28 22:58:05 skylake dhclient[4804]: no link-local IPv6 address for eno1
Mar 28 22:58:05 skylake dhclient[4804]:
Mar 28 22:58:05 skylake dhclient[4804]: If you think you have received this message due to a bug rather
Mar 28 22:58:05 skylake dhclient[4804]: than a configuration issue please read the section on submitting
Mar 28 22:58:05 skylake dhclient[4804]: bugs on either our web page at www.isc.org or in the README file
Mar 28 22:58:05 skylake dhclient[4804]: before submitting a bug. These pages explain the proper
Mar 28 22:58:05 skylake dhclient[4804]: process and the information we find helpful for debugging..
Mar 28 22:58:05 skylake dhclient[4804]:
Mar 28 22:58:05 skylake dhclient[4804]: exiting.

Mike Pontillo (mpontillo) wrote :

Note, this is NOT a case where IPv6 has been disabled explicitly; this is the case where I have a link-down interface. (`ip link` reports NO-CARRIER.)

3: eno1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
    link/ether 0c:c4:7a:c0:31:fa brd ff:ff:ff:ff:ff:ff

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments