[2.1b2] Node failed to be released, because of the following error: 'NoneType' object has no attribute 'addErrback'

Bug #1632815 reported by Nathaniel W. Turner on 2016-10-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Newell Jensen
2.0
Critical
Newell Jensen
Trunk
Critical
Newell Jensen

Bug Description

I now get this whenever I attempt to release a node with "Manual" power type. Nodes with IPMI power type release just fine.

From the syslog:

Oct 12 14:40:11 maas1 maas.node: [INFO] hv6236-vm5: Releasing node
Oct 12 14:40:11 maas1 maas.node: [ERROR] hv6236-vm5: Unable to shut node down: 'NoneType' object has no attribute 'addErrback'
Oct 12 14:40:12 maas1 sh[15833]: 2016-10-12 14:40:11 [-] Error on request (1983) machine.action: 'NoneType' object has no attribute 'addErrback'
Oct 12 14:40:12 maas1 sh[15833]: #011Traceback (most recent call last):
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3.5/threading.py", line 862, in run
Oct 12 14:40:12 maas1 sh[15833]: #011 self._target(*self._args, **self._kwargs)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/provisioningserver/utils/twisted.py", line 801, in worker
Oct 12 14:40:12 maas1 sh[15833]: #011 return target()
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/_threads/_threadworker.py", line 46, in work
Oct 12 14:40:12 maas1 sh[15833]: #011 task()
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/_threads/_team.py", line 190, in doWork
Oct 12 14:40:12 maas1 sh[15833]: #011 task()
Oct 12 14:40:12 maas1 sh[15833]: #011--- <exception caught here> ---
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/python/threadpool.py", line 246, in inContext
Oct 12 14:40:12 maas1 sh[15833]: #011 result = inContext.theWork()
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/python/threadpool.py", line 262, in <lambda>
Oct 12 14:40:12 maas1 sh[15833]: #011 inContext.theWork = lambda: context.call(ctx, func, *args, **kw)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/python/context.py", line 118, in callWithContext
Oct 12 14:40:12 maas1 sh[15833]: #011 return self.currentContext().callWithContext(ctx, func, *args, **kw)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/python/context.py", line 81, in callWithContext
Oct 12 14:40:12 maas1 sh[15833]: #011 return func(*args,**kw)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/provisioningserver/utils/twisted.py", line 834, in callInContext
Oct 12 14:40:12 maas1 sh[15833]: #011 return func(*args, **kwargs)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/utils/orm.py", line 603, in call_within_transaction
Oct 12 14:40:12 maas1 sh[15833]: #011 return func_outside_txn(*args, **kwargs)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/utils/orm.py", line 422, in retrierOct 12 14:40:11 maas1 maas.node: [INFO] hv6236-vm5: Releasing node
Oct 12 14:40:11 maas1 maas.node: [ERROR] hv6236-vm5: Unable to shut node down: 'NoneType' object has no attribute 'addErrback'
Oct 12 14:40:12 maas1 sh[15833]: 2016-10-12 14:40:11 [-] Error on request (1983) machine.action: 'NoneType' object has no attribute 'addErrback'
Oct 12 14:40:12 maas1 sh[15833]: #011Traceback (most recent call last):
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3.5/threading.py", line 862, in run
Oct 12 14:40:12 maas1 sh[15833]: #011 self._target(*self._args, **self._kwargs)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/provisioningserver/utils/twisted.py", line 801, in worker
Oct 12 14:40:12 maas1 sh[15833]: #011 return target()
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/_threads/_threadworker.py", line 46, in work
Oct 12 14:40:12 maas1 sh[15833]: #011 task()
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/_threads/_team.py", line 190, in doWork
Oct 12 14:40:12 maas1 sh[15833]: #011 task()
Oct 12 14:40:12 maas1 sh[15833]: #011--- <exception caught here> ---
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/python/threadpool.py", line 246, in inContext
Oct 12 14:40:12 maas1 sh[15833]: #011 result = inContext.theWork()
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/python/threadpool.py", line 262, in <lambda>
Oct 12 14:40:12 maas1 sh[15833]: #011 inContext.theWork = lambda: context.call(ctx, func, *args, **kw)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/python/context.py", line 118, in callWithContext
Oct 12 14:40:12 maas1 sh[15833]: #011 return self.currentContext().callWithContext(ctx, func, *args, **kw)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/twisted/python/context.py", line 81, in callWithContext
Oct 12 14:40:12 maas1 sh[15833]: #011 return func(*args,**kw)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/provisioningserver/utils/twisted.py", line 834, in callInContext
Oct 12 14:40:12 maas1 sh[15833]: #011 return func(*args, **kwargs)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/utils/orm.py", line 603, in call_within_transaction
Oct 12 14:40:12 maas1 sh[15833]: #011 return func_outside_txn(*args, **kwargs)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/utils/orm.py", line 422, in retrier
Oct 12 14:40:12 maas1 sh[15833]: #011 return func(*args, **kwargs)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3.5/contextlib.py", line 30, in inner
Oct 12 14:40:12 maas1 sh[15833]: #011 return func(*args, **kwds)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/websockets/handlers/machine.py", line 699, in action
Oct 12 14:40:12 maas1 sh[15833]: #011 return action.execute(**extra_params)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/node_action.py", line 400, in execute
Oct 12 14:40:12 maas1 sh[15833]: #011 secure_erase=secure_erase, quick_erase=quick_erase)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/models/node.py", line 2430, in release_or_erase
Oct 12 14:40:12 maas1 sh[15833]: #011 self.release(user, comment)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/models/node.py", line 2328, in release
Oct 12 14:40:12 maas1 sh[15833]: #011 self._release(user)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/models/node.py", line 2346, in _release
Oct 12 14:40:12 maas1 sh[15833]: #011 stopping.addErrback(
Oct 12 14:40:12 maas1 sh[15833]: #011builtins.AttributeError: 'NoneType' object has no attribute 'addErrback'
Oct 12 14:40:12 maas1 sh[15833]: #011

Oct 12 14:40:12 maas1 sh[15833]: #011 return func(*args, **kwargs)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3.5/contextlib.py", line 30, in inner
Oct 12 14:40:12 maas1 sh[15833]: #011 return func(*args, **kwds)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/websockets/handlers/machine.py", line 699, in action
Oct 12 14:40:12 maas1 sh[15833]: #011 return action.execute(**extra_params)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/node_action.py", line 400, in execute
Oct 12 14:40:12 maas1 sh[15833]: #011 secure_erase=secure_erase, quick_erase=quick_erase)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/models/node.py", line 2430, in release_or_erase
Oct 12 14:40:12 maas1 sh[15833]: #011 self.release(user, comment)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/models/node.py", line 2328, in release
Oct 12 14:40:12 maas1 sh[15833]: #011 self._release(user)
Oct 12 14:40:12 maas1 sh[15833]: #011 File "/usr/lib/python3/dist-packages/maasserver/models/node.py", line 2346, in _release
Oct 12 14:40:12 maas1 sh[15833]: #011 stopping.addErrback(
Oct 12 14:40:12 maas1 sh[15833]: #011builtins.AttributeError: 'NoneType' object has no attribute 'addErrback'
Oct 12 14:40:12 maas1 sh[15833]: #011

Versions:

maas 2.1.0~beta2+bzr5454-0ubuntu1~16.04.1

Related branches

Changed in maas:
milestone: none → 2.1.0
importance: Undecided → Critical
summary: - Node failed to be released, because of the following error: 'NoneType'
- object has no attribute 'addErrback'
+ [2.1b2] Node failed to be released, because of the following error:
+ 'NoneType' object has no attribute 'addErrback'
Changed in maas:
status: New → Triaged
Changed in maas:
assignee: nobody → Newell Jensen (newell-jensen)
status: Triaged → In Progress

Hello Nathaniel, or anyone else affected,

Accepted maas into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/2.1.0+bzr5480-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Changed in maas:
status: Fix Committed → Fix Released

The verification of the Stable Release Update for maas has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers