[2.1] Bootloaders not downloaded on initial import

Bug #1630394 reported by Lee Trager on 2016-10-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Lee Trager

Bug Description

On initial startup MAAS is only downloading the default boot image(Xenial) and not the bootloaders. If another import is triggered via user or scheduled import the bootloaders are then downloaded. Enlistment and commissioning are working in the CI because MAAS is falling back to using the system installed PXE bootloader.

Reproduction.
1. Install MAAS in a clean environment
2. Wait for imports to finish and check /var/lib/maas/boot-resources/current
3. See that the PXE bootloaders are symlinks to the system and there is no bootloaders directory.

Related branches

Lee Trager (ltrager) on 2016-10-04
summary: - Bootloaders not downloaded on initial import
+ [2.1] Bootloaders not downloaded on initial import
Changed in maas:
status: Confirmed → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers