[2.1] Command 'interface link-subnet' does not work

Bug #1629604 reported by Peter Matulis on 2016-10-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
High
Blake Rouse

Bug Description

I mark as Broken 'node1' (system id: d77f3f):

$ tail -1000 maas.log | grep -v -e import-images -e sources
Oct 1 19:44:05 maas-lab maas.node: [INFO] node1: Releasing node
Oct 1 19:44:05 maas-lab maas.node: [INFO] node1: Status transition from DEPLOYED to RELEASING
Oct 1 19:44:05 maas-lab maas.node: [INFO] node1: Status transition from RELEASING to BROKEN
Oct 1 19:44:05 maas-lab maas.power: [INFO] Changing power state (off) of node: node1 (d77f3f)
Oct 1 19:44:09 maas-lab maas.power: [INFO] Changed power state (off) of node: node1 (d77f3f)

and I get an error when attempting to link an interface on this node to a subnet:

$ maas admin interface link-subnet d77f3f 63 mode=AUTO subnet=10.248.64.0/19
'NoneType' object has no attribute 'subnet_set'

Details:

$ dpkg-query -W maas
maas 2.1.0~alpha4+bzr5397-0ubuntu1~16.04.1

$ maas admin subnets read
http://paste.ubuntu.com/23261699/

$ maas admin machine read d77f3f
http://paste.ubuntu.com/23261698/

$ tail -f regiond.log &
$ maas admin interface link-subnet d77f3f 63 mode=AUTO subnet=10.248.64.0/19
http://paste.ubuntu.com/23261697/

Observation:

When doing this via the web UI I need to first expose the subnet by selecting a fabric but I do not see this possibility via the syntax of 'interface link-subnet'.

Related branches

Blake Rouse (blake-rouse) wrote :

Can you provide the regiond.log? That log contains debug messages for the region controller.

Changed in maas:
status: New → Incomplete
Peter Matulis (petermatulis) wrote :

@Blake So you need info in regiond.log that was generated prior to me using the command?

Blake Rouse (blake-rouse) wrote :

No there is a regiond.log for that exact API call and error. If you watch the regiond.log when you perform the API call you should see a stacktrace.

Peter Matulis (petermatulis) wrote :

@Blake But I thought I provided this already? I admit it may not be clear but I think you have what you need.

Blake Rouse (blake-rouse) wrote :

Ah yes, didn't see the paste included the regiond log. Thanks.

Changed in maas:
status: Incomplete → New
summary: - Command 'interface link-subnet' does not work
+ [2.1] Command 'interface link-subnet' does not work
Changed in maas:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Blake Rouse (blake-rouse)
milestone: none → 2.1.0
Changed in maas:
status: In Progress → Fix Committed

Hello Peter, or anyone else affected,

Accepted maas into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/2.1.0+bzr5480-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

Tested and confirmed it works as expected.

Changed in maas:
status: Fix Committed → Fix Released
tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for maas has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers