[2.0, 2.1, UI] MAAS webui allows boot disk to be changed on an already deployed node

Bug #1625676 reported by Victor Tapia on 2016-09-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Medium
Blake Rouse
1.9
Undecided
Unassigned
2.0
Undecided
Unassigned
Trunk
Medium
Blake Rouse

Bug Description

In an already deployed node's "storage" section in the MAAS 1.9 webui, the "boot" radio button of a secondary disk can be selected. By doing so, there's no option to select the primary disk again.

Running 'maas maas block-device set-boot-disk <sysid> <devid>' yields the following error: "Cannot set as boot disk because the machine is not Ready'".

I've been able to safely power off and on the machine without issues, so I guess this option is not being used outside commissioning/deploying

Is this the expected behavior? Can we disable the button if it's not used on a deployed node?

Related branches

Andres Rodriguez (andreserl) wrote :

The button needs to be disabled when teh machine is deployed.

Changed in maas:
milestone: none → 2.1.0
importance: Undecided → Medium
status: New → Confirmed
summary: - MAAS webui allows boot disk to be changed on an already deployed node
+ [2.0, 2.1, UI] MAAS webui allows boot disk to be changed on an already
+ deployed node
tags: added: ui
Gavin Panella (allenap) on 2016-09-26
Changed in maas:
status: Confirmed → Triaged
Changed in maas:
status: Fix Committed → Fix Released
Victor Tapia (vtapia) wrote :

I just realized that the fix hasn't landed in 1.9 (the ui issue is still around in 1.9.4). Can you please fix it there too?

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers