MAAS images page doesn't correctly report image status

Bug #1611984 reported by Dean Henrichsmeyer on 2016-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Wishlist
Unassigned

Bug Description

On the MAAS images page, it was reporting that my images were up to date as of today. It was reporting everything was fine.

However, if you looked at the logs you could see that the import job was tracing back every time and failing to import images. There were tons of entries like:

2016-08-04 11:53:56 [-] Downloading images failed.

There are a number of reasons why the import can fail. In this particular case it was a host issue where MAAS couldn't process the downloaded images. Given the logs, there should have been *something* in the UI saying the image update was failing or at the *very* least, not updating the "Last updated" time in the UI.

FWIW, this is MAAS 2.0-rc#

description: updated
Changed in maas:
importance: Undecided → Wishlist
status: New → Confirmed
milestone: none → 2.1.0
tags: added: notifications
tags: added: angularjs yui
Dean Henrichsmeyer (dean) wrote :

To echo our IRC conversation, at a minimum we should not be updating the "last updated" time of the images if the operation fails. This is more than a wishlist. When this happened to me I was sitting in a room where a number of people echoed having encountered the same problem.

Changed in maas:
milestone: 2.0.1 → 2.1.0
Gavin Panella (allenap) on 2016-09-26
Changed in maas:
status: Confirmed → Triaged
Changed in maas:
milestone: 2.1.0 → 2.1.1
Changed in maas:
milestone: 2.1.1 → 2.1.2
Changed in maas:
milestone: 2.1.2 → 2.1.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers