Activity log for bug #1607345

Date Who What changed Old value New value Message
2016-07-28 12:09:15 Jason Hobbs bug added bug
2016-07-28 12:18:35 Andres Rodriguez maas: importance Undecided Wishlist
2016-07-28 12:18:40 Andres Rodriguez maas: milestone next
2016-07-28 12:18:47 Andres Rodriguez maas: status New Triaged
2016-07-28 12:19:03 Andres Rodriguez bug task added cloud-init
2017-05-18 14:41:24 Andres Rodriguez maas: milestone next 2.3.0
2017-07-28 22:24:10 Joshua Powers cloud-init: status New Incomplete
2017-07-28 22:24:15 Joshua Powers bug added subscriber Joshua Powers
2017-07-29 11:40:36 Andres Rodriguez cloud-init: status Incomplete New
2017-08-08 20:37:48 David Britton cloud-init: importance Undecided Wishlist
2017-08-25 17:03:59 Joshua Powers cloud-init: status New Confirmed
2017-08-28 17:26:12 Andres Rodriguez maas: milestone 2.3.0 2.3.x
2017-09-14 04:12:45 Chad Smith cloud-init: assignee Chad Smith (chad.smith)
2017-09-14 04:12:47 Chad Smith cloud-init: status Confirmed In Progress
2017-09-14 04:12:53 Chad Smith cloud-init: milestone 0.7.10
2017-09-14 04:13:14 Chad Smith merge proposal linked https://code.launchpad.net/~chad.smith/cloud-init/+git/cloud-init/+merge/330626
2017-09-23 02:13:49 Scott Moser cloud-init: status In Progress Fix Released
2017-10-06 21:39:52 Launchpad Janitor merge proposal linked https://code.launchpad.net/~chad.smith/cloud-init/+git/cloud-init/+merge/331975
2017-10-12 20:52:22 Brian Murray bug task added cloud-init (Ubuntu)
2017-10-12 20:57:09 Brian Murray cloud-init (Ubuntu Zesty): status New Fix Committed
2017-10-12 20:57:11 Brian Murray bug added subscriber Ubuntu Stable Release Updates Team
2017-10-12 20:57:13 Brian Murray bug added subscriber SRU Verification
2017-10-12 20:57:17 Brian Murray tags oil oil verification-needed verification-needed-zesty
2017-10-12 21:04:37 Brian Murray cloud-init (Ubuntu Xenial): status New Fix Committed
2017-10-12 21:04:45 Brian Murray tags oil verification-needed verification-needed-zesty oil verification-needed verification-needed-xenial verification-needed-zesty
2017-10-25 16:17:10 Chad Smith cloud-init (Ubuntu): status New Fix Released
2017-10-25 16:18:05 Chad Smith description According to https://bugs.launchpad.net/maas/+bug/1604962/comments/12, these logs are needed to debug curtin/cloud-init issues but aren't collected automatically by MAAS: - /var/log/cloud-init* - /run/cloud-init* - /var/log/cloud - /tmp/install.log We need these to be automatically collected by MAAS so we can automatically collect them as artifacts in the case of failures in OIL. curtin/cloud-init issues can be race conditions that are difficult to reproduce manually, so we need to grab the logs required to debug the first time it happens. According to https://bugs.launchpad.net/maas/+bug/1604962/comments/12, these logs are needed to debug curtin/cloud-init issues but aren't collected automatically by MAAS: - /var/log/cloud-init* - /run/cloud-init* - /var/log/cloud - /tmp/install.log We need these to be automatically collected by MAAS so we can automatically collect them as artifacts in the case of failures in OIL. curtin/cloud-init issues can be race conditions that are difficult to reproduce manually, so we need to grab the logs required to debug the first time it happens. http://pad.lv/1607345 https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1607345 === Begin SRU Template === [Impact] ubuntu-bug cloud-init now collects cloud-init-related information for a bug-report [Test Case] # Launch instance under test $ for release in xenial zesty; do ref=$release-proposed; lxc-proposed-snapshot --proposed --publish $release $ref; lxc launch $ref $name; sleep 10; lxc exec $name ubuntu-bug cloud-init # And follow the prompts to report a bogus bug done [Regression Potential] Worst case scenario is the apport wrapper doesn't work and the developer has to file a bug manually instead. [Other Info] Upstream commit at https://git.launchpad.net/cloud-init/commit/?id=ca2730e2ac86b05f7e6 === End SRU Template ===
2017-10-25 16:19:05 Chad Smith tags oil verification-needed verification-needed-xenial verification-needed-zesty oil verification-done verification-done-xenial verification-done-zesty
2017-11-07 17:07:13 Łukasz Zemczak tags oil verification-done verification-done-xenial verification-done-zesty oil verification-done-xenial verification-needed verification-needed-zesty
2017-11-07 17:17:38 Łukasz Zemczak tags oil verification-done-xenial verification-needed verification-needed-zesty oil verification-needed verification-needed-xenial verification-needed-zesty
2017-11-07 19:49:55 Chad Smith tags oil verification-needed verification-needed-xenial verification-needed-zesty oil verification-done verification-done-xenial verification-done-zesty
2017-11-14 22:23:59 Launchpad Janitor cloud-init (Ubuntu Zesty): status Fix Committed Fix Released
2017-11-14 22:24:13 Brian Murray removed subscriber Ubuntu Stable Release Updates Team
2017-11-15 01:07:42 Launchpad Janitor cloud-init (Ubuntu Xenial): status Fix Committed Fix Released
2018-05-30 14:32:47 Andres Rodriguez maas: milestone 2.3.x 2.5.x
2018-05-30 14:34:12 Jason Hobbs tags oil verification-done verification-done-xenial verification-done-zesty cdo-qa foundations-engine oil verification-done verification-done-xenial verification-done-zesty
2018-05-31 18:56:25 Andres Rodriguez nominated for series maas/2.4
2018-05-31 18:56:25 Andres Rodriguez bug task added maas/2.4
2018-05-31 18:56:54 Andres Rodriguez maas/2.4: milestone 2.4.x
2018-05-31 18:56:59 Andres Rodriguez maas/2.4: status New Triaged
2018-05-31 20:00:03 Andres Rodriguez maas: status Triaged Incomplete
2018-05-31 20:00:05 Andres Rodriguez maas/2.4: status Triaged Incomplete
2018-05-31 20:19:34 Andres Rodriguez maas/2.4: milestone 2.4.x 2.4.1
2018-05-31 20:19:47 Andres Rodriguez maas/2.4: milestone 2.4.1 2.4.x
2018-06-02 18:28:27 Dean Henrichsmeyer maas: importance Wishlist High
2018-06-02 18:28:37 Dean Henrichsmeyer maas/2.4: importance Undecided High
2018-07-31 17:43:31 Andres Rodriguez maas: milestone 2.5.x 2.5.0alpha2
2018-08-23 13:44:57 Andres Rodriguez maas: milestone 2.5.0alpha2 2.5.0beta1
2018-09-05 21:07:47 Andres Rodriguez maas: milestone 2.5.0beta1 2.5.0beta2
2018-09-05 21:26:57 Andres Rodriguez maas: milestone 2.5.0beta2 2.5.0
2018-12-21 11:24:49 Andres Rodriguez maas: milestone 2.5.0 2.5.x
2019-03-14 17:35:55 Andres Rodriguez maas: milestone 2.5.x 2.6.0
2019-03-14 17:36:01 Andres Rodriguez bug task deleted maas/2.4
2019-03-14 20:00:14 Chad Smith cloud-init: status Fix Released Confirmed
2019-03-14 20:10:52 Chad Smith cloud-init (Ubuntu): status Fix Released Confirmed
2019-03-14 20:13:39 Chad Smith cloud-init (Ubuntu Xenial): status Fix Released Confirmed
2019-03-14 20:14:00 Chad Smith cloud-init: importance Wishlist Medium
2019-03-14 20:14:09 Chad Smith cloud-init: assignee Chad Smith (chad.smith)
2019-03-14 20:14:26 Chad Smith description According to https://bugs.launchpad.net/maas/+bug/1604962/comments/12, these logs are needed to debug curtin/cloud-init issues but aren't collected automatically by MAAS: - /var/log/cloud-init* - /run/cloud-init* - /var/log/cloud - /tmp/install.log We need these to be automatically collected by MAAS so we can automatically collect them as artifacts in the case of failures in OIL. curtin/cloud-init issues can be race conditions that are difficult to reproduce manually, so we need to grab the logs required to debug the first time it happens. http://pad.lv/1607345 https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1607345 === Begin SRU Template === [Impact] ubuntu-bug cloud-init now collects cloud-init-related information for a bug-report [Test Case] # Launch instance under test $ for release in xenial zesty; do ref=$release-proposed; lxc-proposed-snapshot --proposed --publish $release $ref; lxc launch $ref $name; sleep 10; lxc exec $name ubuntu-bug cloud-init # And follow the prompts to report a bogus bug done [Regression Potential] Worst case scenario is the apport wrapper doesn't work and the developer has to file a bug manually instead. [Other Info] Upstream commit at https://git.launchpad.net/cloud-init/commit/?id=ca2730e2ac86b05f7e6 === End SRU Template === Re-opening this bug as confirmed because the previous SRU content released only provided only 'cloud-init collect-logs'. A command line tool which tars all cloud-init install logs and artifacts for triage. However, those fixes did not provide any configuration options for MAAS to request that those logs are automatically published to MAAS upon error. Cloud-init should provide cloud-config which allows consumers to specify an endpoint and oauth credentials to which cloud-init will automatically POST all compressed cloud-init log artifacts. === Original Description === According to https://bugs.launchpad.net/maas/+bug/1604962/comments/12, these logs are needed to debug curtin/cloud-init issues but aren't collected automatically by MAAS: - /var/log/cloud-init* - /run/cloud-init* - /var/log/cloud - /tmp/install.log We need these to be automatically collected by MAAS so we can automatically collect them as artifacts in the case of failures in OIL. curtin/cloud-init issues can be race conditions that are difficult to reproduce manually, so we need to grab the logs required to debug the first time it happens. === Begin SRU Template === [Impact] ubuntu-bug cloud-init now collects cloud-init-related information for a bug-report [Test Case] # Launch instance under test $ for release in xenial zesty;   do     ref=$release-proposed;     lxc-proposed-snapshot --proposed --publish $release $ref;     lxc launch $ref $name;     sleep 10;     lxc exec $name ubuntu-bug cloud-init # And follow the prompts to report a bogus bug   done [Regression Potential] Worst case scenario is the apport wrapper doesn't work and the developer has to file a bug manually instead. [Other Info] Upstream commit at   https://git.launchpad.net/cloud-init/commit/?id=ca2730e2ac86b05f7e6 === End SRU Template ===
2019-03-14 20:35:57 Chad Smith cloud-init (Ubuntu Zesty): status Fix Released Won't Fix
2019-09-19 11:51:59 Adam Collard maas: status Incomplete Expired