[2.0rc1] MAAS doesn't honor DNS settings for a subnet for DHCP

Bug #1600720 reported by György Szombathelyi on 2016-07-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Mike Pontillo
2.0
Critical
Mike Pontillo
Trunk
Critical
Mike Pontillo

Bug Description

The dns_server setting for a subnet doesn't reflected in dhcpd.conf.

E.g.
maas ... subnets read
.
.
.
    {
        "cidr": "10.97.36.0/24",
        "dns_servers": [
            "109.71.160.1"
        ],
.
.
.

cat /var/lib/maas/dhcpd.conf
.
.
.
    subnet 10.97.36.0 netmask 255.255.255.0 {
           ignore-client-uids true;
           option subnet-mask 255.255.255.0;
           option broadcast-address 10.97.36.255;
           option domain-name-servers 185.13.91.126; #<- this is the MAAS server
.
.
.

This is MaaS 2.0rc1

Related branches

Changed in maas:
status: New → Triaged
importance: Undecided → Critical
Blake Rouse (blake-rouse) wrote :

This somewhat relates to https://bugs.launchpad.net/maas/+bug/1576116. We have not determined what the correct behavior will be.

Andres Rodriguez (andreserl) wrote :

Hi György,

I was wondering if you could provide a bit more information of what you are trying to do? MAAS 2.0 provides a really nice support for DNS and you can set upstream servers that you want MAAS DNS to resolve to. This would allow you not only have MAAS resolve the local maas managed machines DNS names, but also have MAAS forward to your DNS on the network for upstream DNS connectivity.

György Szombathelyi (gyurco) wrote :

The problem is that in our environment, the DNS traffic to the MaaS server is firewalled. So I tought setting the DNS in the subnet should use that DNS server directly (otherwise what is this setting is good for?).

summary: - Maas doesn't honor DNS settings for a subnet for DHCP
+ [2.0rc1] MAAS doesn't honor DNS settings for a subnet for DHCP
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers