[2.0rc1] please drop arm64/efi grub module workaround

Bug #1600285 reported by dann frazier on 2016-07-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Medium
Newell Jensen

Bug Description

uefi_arm64.py has a module filter to workaround bugs in certain grub modules:

                # XXX newell 2015-04-28 bug=1459871,1459872: The module
                # skipping logic below can be removed once the listed bugs have
                # been fixed and released. See listed bugs for details.
                if module_name in ('setjmp', 'setjmp_test', 'progress'):
                    continue

We have fixed all of these issues, and SRU'd them back to trusty. We can now remove this workaround.

Related branches

Revision history for this message
Mike Pontillo (mpontillo) wrote :

Can you confirm that the SRU'd grub code is currently in-use in both the 'daily' and 'releases' streams?

Changed in maas:
status: New → Incomplete
summary: - please drop arm64/efi grub module workaround
+ [2.0rc1] please drop arm64/efi grub module workaround
Revision history for this message
Newell Jensen (newell-jensen) wrote :

There is a branch up for review for this. Simple enough to just do it in case this is moved from being incomplete.

Changed in maas:
assignee: nobody → Newell Jensen (newell-jensen)
importance: Undecided → Medium
Revision history for this message
Mike Pontillo (mpontillo) wrote :

Thanks Newell. We should hold off on landing this until the release stream images are confirmed to contain the fix.

Revision history for this message
Andres Rodriguez (andreserl) wrote : Re: [Bug 1600285] [NEW] please drop arm64/efi grub module workaround

I talked to Sean, and the images aren't affected because we get the boot
loaders directly from
The archive.

On Tuesday, July 12, 2016, Mike Pontillo <email address hidden>
wrote:

> Thanks Newell. We should hold off on landing this until the release
> stream images are confirmed to contain the fix.
>
> --
> You received this bug notification because you are subscribed to MAAS.
> https://bugs.launchpad.net/bugs/1600285
>
> Title:
> [2.0rc1] please drop arm64/efi grub module workaround
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/maas/+bug/1600285/+subscriptions
>

--
Andres Rodriguez (RoAkSoAx)
Ubuntu Server Developer
MSc. Telecom & Networking
Systems Engineer

Revision history for this message
dann frazier (dannf) wrote :

Incomplete->Confirmed as images are not impacted.

Changed in maas:
status: Incomplete → Confirmed
Revision history for this message
Newell Jensen (newell-jensen) wrote :

Dann,

Can you confirm with your arm64/efi setup that this fix is not affecting anything?

Once that is done, I can land the linked branch.

Revision history for this message
dann frazier (dannf) wrote : Re: [Bug 1600285] Re: [2.0rc1] please drop arm64/efi grub module workaround

On Wed, Jul 13, 2016 at 4:09 PM, Newell Jensen
<email address hidden> wrote:
> Dann,
>
> Can you confirm with your arm64/efi setup that this fix is not affecting
> anything?

I applied your change to our MAAS, which Michael Reed is currently
QA'ing. Will let you know if we run into any issues.

Changed in maas:
status: Confirmed → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers