maas 2.0 pxeboot fails on power 8

Bug #1596046 reported by Blake Henderson on 2016-06-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Newell Jensen
2.0
Critical
Newell Jensen

Bug Description

 I have a working environment on ubuntu 14.04 with MAAS 1.9 . MAAS server is a power 812L with 822L nodes and cisco c220 m4 x86 nodes. It works exactly as expected.

I loaded up a cisco c220 with ubuntu 16.04 and installed MAAS 2.0. It recruits x86 nodes without issue but the power 822L i tried will not pxe boot- cannot find the kernel files.

in petitboot i see...

[Network: eth2 / 98:be:94:67:66:a2]
    netboot eth2 (pxelinux.0)

details for netboot eth2 (pxelinux.o)

Device: (*) Specify paths/URLs manually

 Kernel: tftp://10.254.205.15/pxelinux.0
 Ithis is as expected..

but it is missing the execute which should appear below the netboot line and which should point to the actual boot-kernel and boot-initrd files.

Appears that the power can find the maas server but the maas server cannot return the correct pxeboot info.

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===============================-============================-============-=================================================
ii maas 2.0.0~beta3+bzr4941-0ubuntu1 all "Metal as a Service" is a physical cloud and IPAM
ii maas-cli 2.0.0~beta3+bzr4941-0ubuntu1 all MAAS client and command-line interface
un maas-cluster-controller <none> <none> (no description available)
ii maas-common 2.0.0~beta3+bzr4941-0ubuntu1 all MAAS server common files
ii maas-dhcp 2.0.0~beta3+bzr4941-0ubuntu1 all MAAS DHCP server
ii maas-dns 2.0.0~beta3+bzr4941-0ubuntu1 all MAAS DNS server
ii maas-proxy 2.0.0~beta3+bzr4941-0ubuntu1 all MAAS Caching Proxy
ii maas-rack-controller 2.0.0~beta3+bzr4941-0ubuntu1 all Rack Controller for MAAS
ii maas-region-api 2.0.0~beta3+bzr4941-0ubuntu1 all Region controller API service for MAAS
ii maas-region-controller 2.0.0~beta3+bzr4941-0ubuntu1 all Region Controller for MAAS
un maas-region-controller-min <none> <none> (no description available)
un python-django-maas <none> <none> (no description available)
un python-maas-client <none> <none> (no description available)
un python-maas-provisioningserver <none> <none> (no description available)
ii python3-django-maas 2.0.0~beta3+bzr4941-0ubuntu1 all MAAS server Django web framework (Python 3)
ii python3-maas-client 2.0.0~beta3+bzr4941-0ubuntu1 all MAAS python API client (Python 3)
ii python3-maas-provisioningserver 2.0.0~beta3+bzr4941-0ubuntu1 all MAAS server provisioning libraries (Python 3)

Related branches

 my maas release was only at beta 3 -- i added the ppa:next and updated to the latest release

(2.0.0~beta8+bzr5134-0ubuntu1~xenial1)

  Updating to latest release of MAAS 2.0 beta8 had same result--- unable to pxe boot a power 8 node.

Jeff Lane (bladernr) on 2016-06-28
tags: added: blocks-hwcert-server
Changed in maas:
importance: Undecided → Critical
status: New → Confirmed
Changed in maas:
assignee: nobody → Newell Jensen (newell-jensen)
status: Confirmed → In Progress
Changed in maas:
status: In Progress → Incomplete
Changed in maas:
status: Incomplete → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: none → next
Changed in maas:
status: Fix Committed → Fix Released
Changed in maas:
milestone: next → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments