[2.0b6] Cannot allocate a node based on its system_id

Bug #1590991 reported by Mike Pontillo on 2016-06-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Mike Pontillo

Bug Description

When using the "machines allocate" API, there was no way to allocate a node based on its system_id. I first had to look up the hostname. (which could change between API calls, so isn't reliable.)

Related bugs:
 * bug 1074317: cmdline acquire and start is difficult

Related branches

Changed in maas:
milestone: none → 2.0.0
Scott Moser (smoser) wrote :

fwiw, this is really a dupe of bug 1074317.

Scott Moser (smoser) on 2016-06-10
description: updated
Mike Pontillo (mpontillo) wrote :

@smoser, yes - baby steps. ;-)

summary: - Cannot allocate a node based on its system_id
+ [2.0b6] Cannot allocate a node based on its system_id
Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers