No WOL option in latest MAAS version for 16.04

Bug #1589140 reported by qwerty on 2016-06-04
This bug affects 8 people
Affects Status Importance Assigned to Milestone

Bug Description

1.) No WOL option in latest MAAS version for Ubuntu 16.04 (don't know about older version). In the drop down menu for selecting the way that MAAS controls the power of the machines does not include WOL anymore. Is this suppose to be this way?

2.) So I used the manual mode for a test setup. I could add a new machine and when added to the MAAS interface. I then clicked on the "Manual" option for power setup. Then I clicked "Commission" and powered on the machine. It got far in the process until the moment it should restart. The machine turns off (where I would come in and restart the machine) and right after (no more than 2 seconds) the machine as been turned off (by MAAS itself) it gives "Commissioning failed". I tried a couple of times and got the latest version of MAAS, but the problem is still there.

Changed in maas:
status: New → Incomplete
Mike Pontillo (mpontillo) wrote :

Thanks for taking the time to report a bug in MAAS.

(1) The WoL option has indeed been removed from MAAS 2.0. If you want to use WoL, we still support it in MAAS 1.9 on Ubuntu 14.04 (Trusty).

(2) We'll need more information about the reason for the commissioning failure in order to troubleshoot this issue. The following information would be useful:

 - The text printed out on the system console you are trying to commission.
 - The contents of /var/log/maas/rsyslog/<node>, where <node> is the node you are trying to commission. (may be pretty much the same as what is printed out on the console, but easier to obtain)
 - Any information from the "Commissioning Output" section of the "Machine Output" page on the details page for that machine.
 - A description of your network; what network interfaces are in use on the region and rack controllers, what subnets are they attached to? Is MAAS serving DHCP for this network, or is it an external DHCP server?
 - The output of "sudo maas-rack support-dump" from your rack controller.
 - (if all else fails) A packet capture on the rack controller during the commissioning process.

Launchpad Janitor (janitor) wrote :

[Expired for MAAS because there has been no activity for 60 days.]

Changed in maas:
status: Incomplete → Expired
Adam Ryczkowski (adam-9) wrote :

Is there any particular reason, why the WOL was removed in the MAAS 2.0?

Adam Ryczkowski (adam-9) wrote :

For those of you, who are interested, here is a walkaround, that involves patching the MAAS:

Have fun with commodity computing!

Jochen Wezel (jwezel) wrote :

Would be great if this issue could be included assigned on road map to one of the next milestones, e.g. v2.3 (Status is currently "expired" ?!?).

I'd be glad if (as posted by Adam Ryczkowski) could already solve the Wake-On-LAN issue as soon as committed (not yet tested).

Josu (jok-erensuge) wrote :

Sadly it dont work at 2.2.1 :(. It say:

$ sudo patch -p1 -d /usr/lib/python3/dist-packages/provisioningserver/ < maas-wakeonlan.diff

patching file drivers/power/
Hunk #1 FAILED at 353.
Hunk #2 FAILED at 371.
2 out of 2 hunks FAILED -- saving rejects to file drivers/power/
patching file drivers/power/
can't find file to patch at input line 85
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
|diff -Nrup /usr/lib/python3/dist-packages/provisioningserver/power/ provisioningserver/power/
|--- /usr/lib/python3/dist-packages/provisioningserver/power/ 2016-12-21 12:56:19.000000000 +0000
|+++ provisioningserver/power/ 2017-04-02 19:01:59.001823063 +0000
File to patch:
Skip this patch? [y]
Skipping patch.
1 out of 1 hunk ignored

I supose that it's don't apeare...

Deepa (dpaclt) wrote :

Is there any work around or fix for this ?

Changed in maas:
status: Expired → Confirmed
yosefrow (yosefrow) wrote :

I don't understand why this feature was removed. I just tested etherwake now with `etherwake mac-address` on 16.04 and it works perfectly.

Someone created a manual plugin at However, this plugin uses wakeonlan package/binary which for some reason does not seem to work.

So I tried search/replacing every occurence of wakeonlan with etherwake and applying the patch and I still can't get it to work.

Any suggestions?

yosefrow (yosefrow) wrote :

I'm using maas 2.2.2 btw

yosefrow (yosefrow) wrote :

If anyone still has this issue and is not able to use wakeonlan with their machines, You can try the fix I wrote based on another fix that involved wakeonlan.

Follow the instructions in the to install

Basically, only etherwake worked on my system (not wakeonlan) so I rewrote the plugin to use etherwake.

yosefrow (yosefrow) wrote :

Previous link points to a specific commit. The repo link is

Jochen Wezel (jwezel) wrote :

It seems that based on code of yosefrow, there could be an implemented solution for this issue with a minimum of implementation time.

That's why I recommend this issue importance to be upgraded from "undecided" to be part of one of the next milestones.

Blake Rouse (blake-rouse) wrote :

MAAS is designed to scale out with multiple rack controllers spanning multiple racks in a data center. MAAS is also designed in HA where the rack controllers will automatically determine when rack controller can talk to which BMC. This has a requirement that BMC communication must occur using Layer 3 (IP), so the region controllers can determine which racks can communicate to a specific BMC. MAAS also provides retry mechanisms to make sure that when a power action is issued to a BMC that it actually performs the action, with WoL there is no way to get the power status. MAAS also needs to be able to turn a machine off, which it cannot do with WoL.

All of these reasons is why WoL was removed from MAAS and do to the limitations of WoL it most likely will not be added back.

I would recommend getting a APC to control the power of the machines, which MAAS supports.

summary: - No WOL option in latest MAAS version for 16.04 also the Manual settings
- crashes
+ No WOL option in latest MAAS version for 16.04
Blake Rouse (blake-rouse) wrote :

As for the issue with the manual power driver, it seems that the MAC address of the machine is not the MAC address you told MAAS about. The MAC address much match so MAAS knowns what it should do for the booting machine.

Changed in maas:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers