[2.0b5] CI - After changing proxy, MAAS cannot install images

Bug #1585649 reported by Andres Rodriguez on 2016-05-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Blake Rouse

Bug Description

After the recent change of image default mirror, I noticed that the CI started failing. After looking into it, I noticed that the images page showed:

"Error: No boot sources provide Ubuntu images."

I initially figured this was because we are in a completely offline environment, and we have no access to images.maas.io. Later, however, when MAAS now has access to the internet via the Proxy, it still shows the same thing.

What the CI is doing:

1. Change the proxy setting with an external proxy.
2. Tell MAAS to import the images (which actually never happens. Image page shows "Error: No boot sources provide Ubuntu images.").
3. Check for imported images - fails.

What I did to fix this:

1. [CI] Change the proxy setting with an external proxy.
2. [CI] Attempt to import the images.
3. [me] Go to settings page, to the Ephemeral Images and clicked "Save"
4. [me] Go to image listing page, images are now available. Start import manually.
5. [CI] Check for imported images - succeeds, and tests finish successfully.

Related branches

summary: - [2.0b5] After changing proxy, MAAS cannot install images
+ [2.0b5] CI - After changing proxy, MAAS cannot install images
Changed in maas:
milestone: none → 2.0.0
importance: Undecided → Critical
status: New → Confirmed
Changed in maas:
status: Confirmed → In Progress
assignee: nobody → Blake Rouse (blake-rouse)
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers