[2.0b5] Can't force the import of images per Rack Controller

Bug #1583685 reported by Andres Rodriguez on 2016-05-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Jeffrey C Jones

Bug Description

Rack controller's page doens't have a way to force the import of images if for any reason they failed. MAAS needs to provide a way to force it.

Related branches

Changed in maas:
milestone: none → 2.0.0
importance: Undecided → Critical
Gavin Panella (allenap) wrote :

Can you explain the problem? Perhaps we can design MAAS so that it recovers automatically without needing "force" buttons.

Changed in maas:
status: New → Incomplete
Blake Rouse (blake-rouse) wrote :

The rack controller will retry again after importing fails that is already built in. The issue is more of the UI does not provide what the API allows. This call already exists over the API, we just need to add it to the UI as well.

Changed in maas:
status: Incomplete → Triaged
Gavin Panella (allenap) wrote :

The download service loops every 5 minutes, but only downloads if the maas.meta file is at least 15 minutes old. Looping more frequently is therefore quite cheap; changing this to 60 seconds, say, would allow the rack to recover from a transient failure faster than anyone is likely to notice and be able to click the "force" button.

Gavin Panella (allenap) wrote :

[Pressed "Post Comment" too soon.]

I think that would be a better experience for users, and it would mean we could omit the "force" button from the UI and remove the call from the Web API. Fewer moving parts, less work to do, less code to maintain.

summary: - [2.0b5] Can't force the import of images per Rack COntroller
+ [2.0b5] Can't force the import of images per Rack Controller
Changed in maas:
assignee: nobody → Jeffrey C Jones (trapnine)
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers