set_initial_networking_configuration shouldn't raise ValidationError

Bug #1580405 reported by Lee Trager on 2016-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned

Bug Description

The root cause of LP:1580285 was that Node.set_initial_networking_configuration() was raising ValidationError which preventing the processing of commissioning results from completing. What made this bug difficult to track down was that while the exception was being raised it wasn't logged anywhere and commissioning silently failed.

Related branches

Lee Trager (ltrager) wrote :

After speaking with Blake about this it appears that this was due to me raising a ValidationError. ValidationErrors are meant to be user errors(e.g an invalid option passed over the API) and are thus ignored. Changing the validation to use an assert shows the error.

Changed in maas:
status: New → Invalid
Lee Trager (ltrager) on 2016-05-11
Changed in maas:
status: Invalid → In Progress
Lee Trager (ltrager) on 2016-05-11
summary: - Exceptions raised during commissioning not raised
+ set_initial_networking_configuration shouldn't raise ValidationError
Changed in maas:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers