[2.0b4] external maas-rack-controller logs to syslog instead of maas.log

Bug #1577972 reported by Andres Rodriguez on 2016-05-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Unassigned

Bug Description

Connected an external rack controller, but it didn't log import of images:

ubuntu@maas-rack2:~⟫ tail -f /var/log/maas/*.log
==> /var/log/maas/maas.log <==

==> /var/log/maas/rackd.log <==
2016-05-03 22:41:04+0000 [Uninitialized] ClusterClient connection established (HOST:IPv4Address(TCP, '192.168.10.2', 38426) PEER:IPv4Address(TCP, '192.168.10.27', 5250))
2016-05-03 22:41:04+0000 [Uninitialized] ClusterClient connection established (HOST:IPv4Address(TCP, '192.168.10.2', 40226) PEER:IPv4Address(TCP, '192.168.20.104', 5253))
2016-05-03 22:41:05+0000 [ClusterClient,client] Event-loop 'trusty-maas9:pid=6142' authenticated.
2016-05-03 22:41:05+0000 [ClusterClient,client] Event-loop 'trusty-maas9:pid=6144' authenticated.
2016-05-03 22:41:05+0000 [ClusterClient,client] Rack controller '4y3ha6' registered (via trusty-maas9:pid=6142).
2016-05-03 22:41:05+0000 [ClusterClient,client] Rack controller '4y3ha6' registered (via trusty-maas9:pid=6144).
2016-05-03 22:41:34+0000 [-] Event-loop trusty-maas9:pid=6139 (10.216.160.107:5252): User timeout caused connection failure.
2016-05-03 22:41:35+0000 [Uninitialized] ClusterClient connection established (HOST:IPv4Address(TCP, '192.168.10.2', 33936) PEER:IPv4Address(TCP, '192.168.20.104', 5252))
2016-05-03 22:41:35+0000 [ClusterClient,client] Event-loop 'trusty-maas9:pid=6139' authenticated.
2016-05-03 22:41:35+0000 [ClusterClient,client] Rack controller '4y3ha6' registered (via trusty-maas9:pid=6139).

Related branches

Changed in maas:
status: New → Confirmed
importance: Undecided → High
milestone: none → 2.0.0
Lee Trager (ltrager) wrote :

Looks like journalctl is stealing all the messages.

I see the messages in syslog, so we need to look into Rsyslog config!

On Tuesday, May 3, 2016, Lee Trager <email address hidden> wrote:

> Looks like journalctl is stealing all the messages.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1577972
>
> Title:
> [2.0b4] external maas-rack-controller logs to syslog instead of
> maas.log
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/maas/+bug/1577972/+subscriptions
>

--
Andres Rodriguez (RoAkSoAx)
Ubuntu Server Developer
MSc. Telecom & Networking
Systems Engineer

Gavin Panella (allenap) on 2016-05-04
Changed in maas:
status: Confirmed → Triaged
Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers