[2.0 beta 2] If you deploy a machine in MAAS, and manually install a rack controller in it, it disappears from the machine list

Bug #1570985 reported by Andres Rodriguez on 2016-04-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Lee Trager

Bug Description

I had a single machine MAAS deployment, and a few machines in it. I deployed a machine with Ubuntu, and then I manually converted the machine into a Rack Controller.

However, the machine automatically disappeared from the machine listing page as it was now a rack controller.

The problem with that is that I basically lost a machine and cannot re-deploy it without having to enlist / commission it again. This is a broken approach provided that I manually deployed this machine and I should have never lost it.

Related branches

Changed in maas:
importance: Undecided → Critical
milestone: none → 2.0.0
Mike Pontillo (mpontillo) wrote :

Hmm. I vaguely remember a discussion about this. I thought it was by design.

Blake Rouse (blake-rouse) wrote :

Yes we discussed this in a standup one day and we designed that this was the approach we where going to take with MAAS 2.0. Once we add the ability to convert a machine into a rack controller through MAAS we where going to look into handling this correctly. Again I don't think this is something we can handle easily in MAAS 2.0 and should be something we look to tackle in MAAS 2.1. I don't believe we can fix this bug without causing more issues in MAAS 2.0.

I would suggest targeting this towards "MAAS next" verses "2.0".

Changed in maas:
status: New → Confirmed
Gavin Panella (allenap) on 2016-05-04
Changed in maas:
status: Confirmed → Triaged
Lee Trager (ltrager) wrote :

The linked MP solves this by allowing a machine to transition from a machine to a rack controller and back. It also adds a trigger so nodes which transition between types should be reflected in the UI almost instantly.

Changed in maas:
assignee: nobody → Lee Trager (ltrager)
status: Triaged → In Progress
Lee Trager (ltrager) on 2016-05-26
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers