maas enlistment of power8 found ipmi 1.5 should do ipmi 2.0

Bug #1556219 reported by Scott Moser on 2016-03-11
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
MAAS
High
Andres Rodriguez
1.9
High
Unassigned

Bug Description

I enlisted a power system in maas.
maas correctly got its ipmi credentials set up, but then would not commission the sytem because it insisted that the power was 'on'.

The ipmi credentials were all correct, but the power type was set to LAN [IPMI 1.5].

Switching it to 2.0 and everything worked fine.
for power arch 2.0 is always going to be right (until ipmi 3.0...)

Related branches

Ryan Beisner (1chb1n) on 2016-04-01
Changed in maas:
status: New → Confirmed
Ryan Beisner (1chb1n) wrote :

This workaround isn't working well for me. I keep having boxes revert to 1.5, then go into Releasing Failed. I've got to manually toggle back to 2.0, release, then attempt redeploy.

Changed in maas:
status: Confirmed → New
Changed in maas:
status: New → Confirmed
status: Confirmed → Triaged
Andres Rodriguez (andreserl) wrote :

Scott, can you attache the output of:

bmc-info -L
ipmi-locate

Thanks

Changed in maas:
milestone: none → 2.0.0
Andres Rodriguez (andreserl) wrote :

on power, we should be assuming we will be using ipmi 2.0 instead of 1.5.

Changed in maas:
assignee: nobody → Andres Rodriguez (andreserl)
Scott Moser (smoser) wrote :

Andres had asked me to post ipmi-locate output. So here it is for reference. He indicated that they expect to find an ipmi version in the output and assume 1.5 if its not there.

$ sudo ipmi-locate
Probing KCS device using DMIDECODE... ERROR: permission denied
Probing SMIC device using DMIDECODE... ERROR: permission denied
Probing BT device using DMIDECODE... ERROR: permission denied
Probing SSIF device using DMIDECODE... ERROR: permission denied
Probing KCS device using SMBIOS... ERROR: permission denied
Probing SMIC device using SMBIOS... ERROR: permission denied
Probing BT device using SMBIOS... ERROR: permission denied
Probing SSIF device using SMBIOS... ERROR: permission denied
Probing KCS device using ACPI... ERROR: permission denied
Probing SMIC device using ACPI... ERROR: permission denied
Probing BT device using ACPI... ERROR: permission denied
Probing SSIF device using ACPI... ERROR: permission denied
Probing KCS device using PCI... FAILED
Probing SMIC device using PCI... FAILED
Probing BT device using PCI... FAILED
Probing SSIF device using PCI... FAILED

Changed in maas:
status: Triaged → Confirmed
importance: Undecided → High
Changed in maas:
status: Confirmed → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers