Unconfigured interfaces shouldn't add DNS records

Bug #1553665 reported by Koaps on 2016-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
LaMont Jones

Bug Description

I'm struggling with trying to keep MAAS dns straight when it comes to static IP's on Bonds.

My servers have 4 NICS, 2x 1GB (eth0 and eth1) and 2x 10GB (eth3 and eth4).

These particular servers only PXE over eth0 or eth1 and I bond eth3 and eth4 together to make bond0.

After commissioning the server, I set a static IP on bond0 and want the DNS record to be this IP.

I set both eth0 and eth1 as Unconfigured for both the subnet and IP, yet DNS still points to eth0's discovered IP.

This isn't always the case, sometimes it sets it to bond0 static IP.

The MAAS DNS shouldn't point to unconfigured interfaces, it would almost be better to have no record at all than one pointing to an IP that won't exist when the node is deployed (since it's a dynamic IP that could be assigned to another node later on)

Related branches

Andres Rodriguez (andreserl) wrote :

Hi There,

In any MAAS version earlier than 2.0, the DNS record will ONLY be made against the PXE Interface IP address.

In 2.0 or later version, the DNS A record will ONLY be made against the PXE Interface IP address, and PTR records will be made on other interfaces.

This is done by design.

Changed in maas:
status: New → Incomplete
status: Incomplete → Won't Fix
status: Won't Fix → Confirmed
milestone: none → 2.0.0
milestone: 2.0.0 → none
status: Confirmed → New
milestone: none → 2.0.0
Andres Rodriguez (andreserl) wrote :

Ok, as for the second part, yes, there should be no records made against interfaces with no IP addresses whatsoever. My guess is that what you are seeing is that there's a list of IP addresses from the Dynamic ranges, and may have a stale record.

Changed in maas:
importance: Undecided → Critical
Koaps (koaps) wrote :

Hi Andres,

Because we have a very small dynamic pool ( 5 ips), we flush the leases before adding new servers.

This works fine for DHCP, but it seems that the DNS isn't updating, maybe when the IP is assigned to a new server during commissioning the old server creates a record for the static IP on the bond0, since some of the servers have the right IP in DNS. The particular server giving me the issue was the last one deployed.

I guess there's no plans to allow the DNS record for the node to be set via the API ?

LaMont Jones (lamont) wrote :

Is the issue still occurring with 2.0 alpha2?

Changed in maas:
status: New → Incomplete
Andres Rodriguez (andreserl) wrote :

This is the output of DNS.

two machines with hostname maas-enlist have DNS records for, however, these machines are not powered on. These IP's for the 'maas-enlist' machines are from the dynamic range.

Changed in maas:
status: Incomplete → Confirmed
Gavin Panella (allenap) on 2016-03-16
Changed in maas:
status: Confirmed → Triaged
Andres Rodriguez (andreserl) wrote :

I noticed a whole bunch of IP addresses on the dynamic range that had been enlisting had records added:

maas-enlist A192.168.10.58
maas-enlist A192.168.10.70
maas-enlist A192.168.10.52
maas-enlist A192.168.10.67
maas-enlist A192.168.10.62
maas-enlist A192.168.10.54

I think that MAAS shouldn't be adding records for these kinds of things

LaMont Jones (lamont) on 2016-04-12
Changed in maas:
assignee: nobody → LaMont Jones (lamont)
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers