API allows attaching physical, bond interface to VLAN with a known tag (Inconsistent with UI)

Bug #1552923 reported by Blake Rouse on 2016-03-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Blake Rouse
1.9
High
Blake Rouse

Bug Description

The API currently allows administrators to attach a physical or bond interface to a VLAN which is not an untagged vlan on a fabric. This does not match the UI which limits this. Also a VLAN interface can be attached to the untagged VLAN for the fabric.

This is inconsistent with the WebUI. Either MAAS supports placing a physical or bond interface on any VLAN or only the untagged VLAN. We cannot allow the API to do one thing and the UI to do another. It causes confusing for users, its in consistent, and its overall bad UX. Either we support one way or we support the other way, not 50% one way and 50% the other.

Tags: api Edit Tag help

Related branches

summary: - API allows attaching physical, bond interface to non untagged VLAN's
+ API allows attaching physical, bond interface to VLAN with a known tag

Clarified title to make it clear what the issue is. (Previously the title referred to the term "untagged" as a property of the VLAN.)

MAAS currently refers to the "default" VLAN in a fabric as "untagged". This is ambiguous to MAAS administrators, since fabrics may have more than one "untagged" VLAN depending on the switch port. (That is, "untagged on VLAN X" is a property of a switch port.)

The MAAS out-of-the-box experience works best when all switch ports are on the same default ("untagged") VLAN, as that eliminates the ambiguity. (less unknowns are better for MAAS, since we don't model switches or switch ports.) But it is possible (and VERY common) to have more than one "untagged" VLAN per fabric. So by "fixing" this bug, we would effectively be forcing users to model a single fabric as two fabrics - a showstopper issue that prevents any customers who have shared VLANs between the "two" fabrics from using MAAS.

summary: API allows attaching physical, bond interface to VLAN with a known tag
+ (Inconsistent with UI)
description: updated
Blake Rouse (blake-rouse) wrote :

"So by "fixing" this bug, we would effectively be forcing users to model a single fabric as two fabrics - a showstopper issue that prevents any customers who have shared VLANs between the "two" fabrics from using MAAS."

You are correct that it will prevent users from performing an action that they should not be allowed to do. At the current state in time we do not support that mode of operation. So in reality by not "fixing" this bug, you are deliberaly accepting that a users experience with MAAS will be inconsistent and an overall bad UX. That is unacceptable.

Changed in maas:
status: Triaged → Fix Committed
no longer affects: maas/1.10
Changed in maas:
assignee: nobody → Blake Rouse (blake-rouse)
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers