[1.10] Network aliases are created during commissioning with Xenial (not trusty)

Bug #1542349 reported by Chris Gregan
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Unassigned
1.10
Critical
Mike Pontillo
1.9
Critical
Unassigned

Bug Description

Build Version/Date: MAAS Version 1.10.0 (+bzr4577)
Environment used for testing: Xenial commissioning and Deploy

Summary:
Networking aliases are created automatically when systems are commissioned

Steps to Reproduce:
1) Commission a node with multiple networking devices

Expected result:
Only physical networking devices are shown

Actual result:
Aliases are created automatically

Related branches

Chris Gregan (cgregan)
tags: added: cdo-qa
no longer affects: maas/2.0
summary: - Network aliases are created during commissioning
+ Network aliases are created during commissioning with Xenial (not
+ trusty)
Changed in maas:
milestone: none → 2.0.0
no longer affects: maas/1.9
summary: - Network aliases are created during commissioning with Xenial (not
+ [1.10] Network aliases are created during commissioning with Xenial (not
trusty)
summary: - [1.10] Network aliases are created during commissioning with Xenial (not
- trusty)
+ [1.10] Network aliases are created during commissioning with Xenial
+ (not trusty)
Changed in maas:
status: New → Confirmed
Changed in maas:
importance: Undecided → Critical
Revision history for this message
Mike Pontillo (mpontillo) wrote :

This is not an issue for 1.9 since we will not commission with a Xenial image.

I have triaged this and reproduced the issue on 1.10.

Revision history for this message
Mike Pontillo (mpontillo) wrote :

I've been unit testing the commissioning scripts in MAAS 2.0 and have so far not hit this issue.

I'll try again on the 1.10 branch.

Revision history for this message
Mike Pontillo (mpontillo) wrote :

I've verified that the lower layers seem okay, so I'm pretty sure now that the issue is in Node.set_initial_networking_configuration(). I had assumed this was an issue with something like interface names ('eth' -> 'ens'), but haven't found that to be true so far. So I'm not sure what's special about Xenial yet.

Revision history for this message
Mike Pontillo (mpontillo) wrote :

It seems that for some reason, when commissioning a Xenial node, the StatusHandler runs multiple times. For example, from my maas.log:

Feb 11 21:50:59 maastest maas.node: [INFO] triple-managed1: Storage layout was set to flat.
Feb 11 21:51:02 maastest maas.node: [INFO] triple-managed1: Storage layout was set to flat.
Feb 11 21:52:16 maastest maas.node: [INFO] triple-managed1: Storage layout was set to flat.

This was from a single commissioning attempt.

I believe that is the root cause of this issue.

Changed in maas:
status: Confirmed → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers