cluster controller failing to detect interfaces on bootstrap

Bug #1519810 reported by Edward Hope-Morley on 2015-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned
1.8
High
Unassigned

Bug Description

When MAAS is installed it will automatically create a cluster controller and register it with the region controller (according to https://maas.ubuntu.com/docs/development/cluster-registration.html#first-cluster). When the cluster controller starts it attempts to autodiscover network interfaces and use one of the to connect to the region controller. In general this seems to work fine although we are seeing cases where maas fails to autodiscover interfaces and thus fails to connect.

The docs at https://maas.ubuntu.com/docs/cluster-configuration.html state that "Cluster interfaces are discovered automatically, though this may not happen e.g. if the network interface was down when MAAS was installed" yet this does not appear to have happened since all interfaces were UP at the time maas was installed/started.

/var/log/maas.log - http://paste.ubuntu.com/13501984/

The following sequence of commands provides a way to get the cluster up but I think this is a bug in MAAS:

http://paste.ubuntu.com/13501931/

This is an easily reproducible problem in our env by simply deleting the controller and rebooting MAAS. We are always able to recover by manually adding an interface to the controller.

summary: - cluser controller failing to detect interfaces on bootstrap
+ cluster controller failing to detect interfaces on bootstrap
Andres Rodriguez (andreserl) wrote :

Hi Edward,

What interfaces are these? MAAS 1.9+ won't detect virtual interface, it would only detect physical interfaces.

Thanks.

tags: added: doc
Mike Pontillo (mpontillo) wrote :

Adding the 'doc' tag since we need to at least document the new behavior.

Meanwhile, it would be nice to know which interfaces are being ignored, and why. So, two questions:

(1) Which version of Ubuntu are you running, and which networks do you expect to see that aren't showing up?

(2) Can you run the following script and add the output to this bug?
    http://paste.ubuntu.com/13524355/

Edward Hope-Morley (hopem) wrote :

@anderserl @mpontillo

See http://paste.ubuntu.com/13501931/ - Currently all interfaces are ignored and these are all interfaces (eth0, eth1 etc) within a vm that MAAS has not previously had any problems in detecting (in a vm). On another vm where i have have just eth0 it seems to work just fine. This is Ubuntu Trusty and I would expect at least eth0 to be detected (since that has been the behaviour until now).

Output of your script + maas version - http://paste.ubuntu.com/13581622/

Mike Pontillo (mpontillo) wrote :

Thanks for the information. I think this is a duplicate of #1519919. Please let us know if the issue is solved when that lands!

Mike Pontillo (mpontillo) wrote :

Actually, I take that back. (Sorry, I missed the part where this was MAAS 1.8.3.) In that case, this needs to be looked at again. I didn't think we changed MAAS 1.8 to filter interfaces differently.

I see from the hostname that this is a virtual machine; what type of virtual NICs are you using?

Mike Pontillo (mpontillo) wrote :

Also, did you add the interfaces before or after you installed the MAAS cluster controller for the first time? (We only discover the interfaces at install time.)

no longer affects: maas/trunk
no longer affects: maas/1.9
Changed in maas:
status: New → Incomplete
milestone: none → next
Mike Pontillo (mpontillo) wrote :

Sorry for the spam; I also noticed that there was an "Internal server error" reported when you tried to add the cluster interface via the CLI.

Can you check for a corresponding exception in /var/log/maas/regiond.log, and attach it to this bug?

tags: added: sts
Edward Hope-Morley (hopem) wrote :

I'm no longer seeing this issue (with MAAS 1.9).

Changed in maas:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers