[1.9rc1] Cache needs to be refreshed to not show garbage after ugprades

Bug #1515380 reported by Ante Karamatić on 2015-11-11
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Blake Rouse

Bug Description

It's impossible to create or delete or in any way manage bonds in RC1.

When one selects NICs to create a bond, new interface shows up, but one can only replace name 'bond0' with a custom name. There's nothing else that can be done. And there's no way to save new setup - as soon as one goes to another page, all changes are discarded.

Screenshot attached.

Tags: ui Edit Tag help

Related branches

Ante Karamatić (ivoks) wrote :
Ante Karamatić (ivoks) wrote :

Looks like it's more than this. I can't even add an alias to existing interface. UI just greys out everything and doesn't do anything after that.

Blake Rouse (blake-rouse) wrote :

This has already been fixed in trunk and will be released in 1.9 rc1.

Changed in maas:
status: New → Fix Committed
importance: Undecided → Critical
milestone: none → 1.9.0
Andres Rodriguez (andreserl) wrote :

Hi Ante,

Is your machine in 'Ready' state?

Changed in maas:
status: Fix Committed → New
Andres Rodriguez (andreserl) wrote :

@Blake,

He is running the lastest trunk as of today.

Then he needs to try and clear his cache.
On Nov 11, 2015 6:20 PM, "Andres Rodriguez" <email address hidden> wrote:

> @Blake,
>
> He is running the lastest trunk as of today.
>
> --
> You received this bug notification because you are subscribed to MAAS.
> https://bugs.launchpad.net/bugs/1515380
>
> Title:
> [1.9rc1] Network bonds management unresponsive in UI
>
> Status in MAAS:
> New
>
> Bug description:
> It's impossible to create or delete or in any way manage bonds in RC1.
>
> When one selects NICs to create a bond, new interface shows up, but
> one can only replace name 'bond0' with a custom name. There's nothing
> else that can be done. And there's no way to save new setup - as soon
> as one goes to another page, all changes are discarded.
>
> Screenshot attached.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/maas/+bug/1515380/+subscriptions
>

Confirmed, clearing cache in the browser solves the problem. Maybe for 2.0 you could think about renaming CSS/JS files to contain MAAS version number. That way you will prevent things like this. I suspect this will hit others as well unless it's isolated only to 1.9b2->1.9rc1 upgrade path. I haven't tried 1.8->1.9rc1 upgrade, maybe that wouldn't happen in normal scenario.

summary: - [1.9rc1] Network bonds management unresponsive in UI
+ [1.9rc1] Cache needs to be refreshed to not show garbage after ugprades
Changed in maas:
status: New → In Progress
assignee: nobody → Blake Rouse (blake-rouse)
tags: added: ui
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers