Data Loggers PDU unit does not shutdown outlet after commissioning or deploying a connected node

Bug #1506053 reported by Ryan Collis on 2015-10-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Newell Jensen

Bug Description

We have several ARM64 nodes power controlled by a Data Loggers PDU unit. When commissioning or deployment of a node completes, the node itself is powered off.. However the corresponding PDU outlet remains in the powered on state. The node/outlet must be powered off via the MAAS interface (Take Action > Power Off menu) before any further action can be taken with the attached node (as MAAS continues to see the node as powered on). Please note that we have observed this from ver 1.8+. Current Version Below

dpkg -l '*maas*'|cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============================-===================================-============-======================================
ii maas 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS server all-in-one metapackage
ii maas-cli 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS command line API tool
ii maas-cluster-controller 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS server cluster controller
ii maas-common 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS server common files
ii maas-dhcp 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS DHCP server
ii maas-dns 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS DNS server
ii maas-proxy 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS Caching Proxy
ii maas-region-controller 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS server complete region controller
ii maas-region-controller-min 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS Server minimum region controller
ii python-django-maas 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS server Django web framework
ii python-maas-client 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS python API client
ii python-maas-provisioningserver 1.9.0~alpha4+bzr4371-0ubuntu1~wily1 all MAAS server provisioning libraries

Related branches

Ryan Collis (vyan) on 2015-10-14
tags: added: commission power type
mahmoh (mahmoh) wrote :

I believe the power template requires a fix to detect the state properly:

--- dli.template-orig 2015-06-12 14:22:28.000000000 -0400
+++ dli.template 2015-06-27 23:33:22.791550733 -0400
@@ -18,11 +18,11 @@
 query_state() {
   state=$(wget --auth-no-challenge -qO- \
     http://${power_user}:${power_pass}@${power_address}/index.htm |\
- grep '<!-- state=' | awk '{print $2}' | cut -f 2 -d '=')
+ grep '<!-- state=' | awk '{print $2}' | cut -f 2 -d '=' | tr 'a-f'
'A-F')
   shift=$((1 << ($system_id-1)))
   if [ -z $state ]; then
     echo "unknown"
- elif [ $((${state#0} & $shift )) -gt 0 ]; then
+ elif [ $(( `echo "ibase=16; $state" | bc` & $shift )) -gt 0 ]; then
     echo "on"
   else
     echo "off"

Changed in maas:
assignee: nobody → Newell Jensen (newell-jensen)
status: New → Triaged
milestone: none → 1.9.0
mahmoh (mahmoh) wrote :

Note: my comment, #1, might be a separate bug than what the submitter intended, please verify.

Changed in maas:
status: Triaged → New
Changed in maas:
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → High
Ryan Collis (vyan) wrote :

I obviously made an error in this bug report. Just noticed that Data Loggers should read Digital Loggers.

Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers