[1.9.0 alpha3] can't add physical interface

Bug #1503479 reported by Carla Berkers on 2015-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Blake Rouse

Bug Description

With the implementation of the new node networking layout, we have lost the ability to add physical interfaces

Related branches

Blake Rouse (blake-rouse) wrote :

This is a regression from 1.8. We need to be able to do this in 1.9.

You will need to specify the name, MAC address, fabric and vlan for the interface. You could even specify the subnet and IP address at the same time.

Changed in maas:
status: New → Triaged
importance: Undecided → Critical
tags: added: regression
Changed in maas:
milestone: none → 1.9.0
Andres Rodriguez (andreserl) wrote :

Can you please try to reproduce this with 1.9.0alpha4 ? In the meantime I'm marking this as incomplete. If this is still being experience,d please, mark it as New.

Changed in maas:
status: Triaged → Incomplete
status: Incomplete → Triaged
Andres Rodriguez (andreserl) wrote :

Forget about my last message :).

Carla Berkers (carlaberkers) wrote :

attached the design as we discussed yesterday.

please note:
1. PXE is the second column
only on pxe interface, no empty radiobuttons on other interfaces as can’t change

2. change IP Address label to IP assignment
IP assignmnet when editable, IP address when deployed

3. no labels on first row
keep name and mac in the same order

4. when no interfaces are selected:, add interface button is active
one or more interface selected, add interface button is deactivated

Changed in maas:
assignee: Carla Berkers (carlaberkers) → Blake Rouse (blake-rouse)
Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers