default install failed in lvcreate

Bug #1502259 reported by Scott Moser on 2015-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Blake Rouse

Bug Description

I just upgraded to 1.9, tried an install and fail ed deploy with:
   Volume group "vgroot" has insufficient free space (38145 extents): 38146 required.
  An error occured handling \'vgroot-lvroot\': ProcessExecutionError - Unexpected error while running command.
  Command: [\'lvcreate\', \'vgroot\', \'-n\', \'lvroot\', \'-L\', \'159995920384B\']

$ dpkg-query --show python-curtin maas
maas 1.9.0~alpha2+bzr4322-0ubuntu1~trusty1
python-curtin 0.1.0~bzr270-0ubuntu1~trusty0

$ maas home-smoser block-devices read node-787b19d8-d25c-11e4-9f9e-00163eca91de
Success.
Machine-readable output follows:
[
    {
        "size": 160000000000,
        "resource_uri": "/MAAS/api/1.0/nodes/node-787b19d8-d25c-11e4-9f9e-00163eca91de/blockdevices/1/",
        "uuid": null,
        "tags": [
            "rotary",
            "sata"
        ],
        "name": "sda",
        "partition_table_type": "MBR",
        "filesystem": null,
        "id_path": "/dev/disk/by-id/ata-ST3160812AS_5LSD9ZFA",
        "path": "/dev/disk/by-dname/sda",
        "model": "ST3160812AS",
        "block_size": 4096,
        "type": "physical",
        "id": 1,
        "serial": "5LSD9ZFA",
        "partitions": [
            {
                "uuid": "5c6e1bcb-43de-4558-a2fb-93841e06c10c",
                "bootable": false,
                "filesystem": {
                    "mount_point": null,
                    "uuid": "c7be5fcf-c114-4c81-a71d-ca116747b60c",
                    "fstype": "lvm-pv",
                    "label": null
                },
                "path": "/dev/disk/by-dname/sda-part1",
                "resource_uri": "/MAAS/api/1.0/nodes/node-787b19d8-d25c-11e4-9f9e-00163eca91de/blockdevices/1/partition/1",
                "type": "partition",
                "id": 1,
                "size": 159996854272
            }
        ]
    },
    {
        "size": 159995920384,
        "resource_uri": "/MAAS/api/1.0/nodes/node-787b19d8-d25c-11e4-9f9e-00163eca91de/blockdevices/2/",
        "uuid": "90cf6a7a-39ec-4448-b34c-35884db14fc2",
        "tags": [],
        "name": "vgroot-lvroot",
        "partition_table_type": null,
        "filesystem": {
            "mount_point": "/",
            "uuid": "b94d4cfa-d3c3-4fb7-b30d-d199c0b1ee95",
            "fstype": "ext4",
            "label": "root"
        },
        "id_path": null,
        "path": "/dev/disk/by-dname/lvroot",
        "model": null,
        "block_size": 4096,
        "type": "virtual",
        "id": 2,
        "serial": null,
        "partitions": []
    }
]

Related bugs:
 * bug 1487114: Failed to deploy with LVM layout

Related branches

Scott Moser (smoser) wrote :
description: updated
Changed in maas:
status: Confirmed → Triaged
importance: Undecided → Critical
milestone: none → 1.9.0
tags: added: storage
Changed in maas:
status: Triaged → In Progress
assignee: nobody → Blake Rouse (blake-rouse)
Scott Moser (smoser) wrote :

this worked for me now with:
maas 1.9.0~alpha5+bzr4398-0ubuntu1~trusty1
python-curtin 0.1.0~bzr276-0ubuntu1~trusty1

Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers