Exception in bootresources.py prevents downloading boot pxe images

Bug #1499749 reported by Radomir on 2015-09-25
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Gavin Panella
1.8
Critical
Blake Rouse
simplestreams (Ubuntu)
Critical
Unassigned
Trusty
Critical
Unassigned
Vivid
Critical
Unassigned
Wily
Critical
Unassigned

Bug Description

On newly installed MAAS server (1.8.2) on LTS (Ubuntu 14.04) I'm not able to download PXE images.

in clusterd.log I have an exception:

2015-09-25 15:28:29 [-] Exception in thread Thread-187:
2015-09-25 15:28:29 [-] Traceback (most recent call last):
2015-09-25 15:28:29 [-] File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
2015-09-25 15:28:29 [-] self.run()
2015-09-25 15:28:29 [-] File "/usr/lib/python2.7/threading.py", line 763, in run
2015-09-25 15:28:29 [-] self.__target(*self.__args, **self.__kwargs)
2015-09-25 15:28:29 [-] File "/usr/lib/python2.7/dist-packages/maasserver/utils/orm.py", line 404, in call_within_transaction
2015-09-25 15:28:29 [-] return func_outside_txn(*args, **kwargs)
2015-09-25 15:28:29 [-] File "/usr/lib/python2.7/dist-packages/maasserver/utils/orm.py", line 300, in retrier
2015-09-25 15:28:29 [-] return func(*args, **kwargs)
2015-09-25 15:28:29 [-] File "/usr/lib/python2.7/dist-packages/django/db/transaction.py", line 339, in inner
2015-09-25 15:28:29 [-] return func(*args, **kwargs)
2015-09-25 15:28:29 [-] File "/usr/lib/python2.7/dist-packages/maasserver/bootresources.py", line 687, in write_content_thread
2015-09-25 15:28:29 [-] self.write_content(rfile, reader)
2015-09-25 15:28:29 [-] File "/usr/lib/python2.7/dist-packages/maasserver/bootresources.py", line 656, in write_content
2015-09-25 15:28:29 [-] cksummer = sutil.checksummer(
2015-09-25 15:28:29 [-] AttributeError: 'module' object has no attribute 'checksummer'

full log here:
http://paste.ubuntu.com/12554272/

this is caused by the change in simplestreams python module:

 - checksummer class is now a part of checksum_util module instead of util module

FIX:
edit:

/usr/lib/python2.7/dist-packages/maasserver/bootresources.py

and add:
from simplestreams import checksum_util as cutil

then in function write_content you change:

cksummer = sutil.checksummer(

to:

cksummer = cutil.checksummer(

and it works again

Changed in maas:
status: New → Fix Committed
milestone: none → 1.9.0
importance: Undecided → Critical
Changed in maas:
assignee: nobody → Gavin Panella (allenap)
Scott Moser (smoser) on 2015-09-25
Changed in simplestreams (Ubuntu):
status: New → Confirmed
Changed in simplestreams (Ubuntu Trusty):
status: New → Confirmed
Changed in simplestreams (Ubuntu Vivid):
status: New → Confirmed
Changed in simplestreams (Ubuntu Trusty):
importance: Undecided → Critical
Changed in simplestreams (Ubuntu Vivid):
importance: Undecided → Critical
Changed in simplestreams (Ubuntu Wily):
importance: Undecided → Critical
Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simplestreams - 0.1.0~bzr341-0ubuntu2.3

---------------
simplestreams (0.1.0~bzr341-0ubuntu2.3) trusty-security; urgency=high

  * export checksummer in simplestreams.util (LP: #1499749)
    Users of simplestreams.util checksummer would get an AttributeError
    because this was moved.

 -- Scott Moser <email address hidden> Fri, 25 Sep 2015 11:15:24 -0400

Changed in simplestreams (Ubuntu Trusty):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simplestreams - 0.1.0~bzr354-0ubuntu1.15.04.2

---------------
simplestreams (0.1.0~bzr354-0ubuntu1.15.04.2) vivid-security; urgency=high

  * export checksummer in simplestreams.util (LP: #1499749)
    Users of simplestreams.util checksummer would get an AttributeError
    because this was moved.

 -- Scott Moser <email address hidden> Fri, 25 Sep 2015 11:19:55 -0400

Changed in simplestreams (Ubuntu Vivid):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package simplestreams - 0.1.0~bzr401-0ubuntu1

---------------
simplestreams (0.1.0~bzr401-0ubuntu1) wily; urgency=high

  * New upstream snapshot.
    - export checksummer in simplestreams.util (LP: #1499749)

 -- Scott Moser <email address hidden> Fri, 25 Sep 2015 10:52:51 -0400

Changed in simplestreams (Ubuntu Wily):
status: Confirmed → Fix Released
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers