node-interfaces create-bond API specifies parents in an awkward way

Bug #1495845 reported by Mike Pontillo on 2015-09-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Medium
Unassigned

Bug Description

When I use the node-interfaces create-bond API to create a bond, I need to specify its parent interfaces. To do so, I use a command like:

maas admin node-interfaces create-bond node-d83ce230-4b50-11e5-a267-00163eb185eb name=bond0 vlan=0 parents=30 parents=31 mac_address=00:50:56:2b:60:53

This is awkward, since a user would expect to list multiple parents after the "parents" parameter, such as "parents=30,31".

If we keep it the way it is, it would be better to rename the parameter to "parent".

Blake Rouse (blake-rouse) wrote :

This happens to be because of the way the maascli works with regards to the use of a multiplechoicemodelfield. I am open to changing the parameter to just parent, and is a very simple change.

Blake Rouse (blake-rouse) wrote :

We need to make this change very soon because once it is released there is no changing it.

Andres Rodriguez (andreserl) wrote :

Also, can we do parents=eth0,eth1 ?

Changed in maas:
milestone: none → 1.9.0
Mike Pontillo (mpontillo) wrote :

Let's rename the current parameter (parents=) that takes an id to parent= first.

I like the suggestion from Andres of allowing parents=<ifname1>,<ifname2>[,...] - if it's a quick fix, we could do that with this fix, too, otherwise it sounds like a separate bug.

Changed in maas:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers