When no HWE kernels for a release, MAAS UI shows "string index out of range"

Bug #1490709 reported by Andres Rodriguez on 2015-08-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Lee Trager

Bug Description

I imported Precise and Trusty from the daily streams, and accesing the node listing page went fine, no issues.

After I imported vivid, I started seeing the "string index out of range". I deleted the Vivid image (by removing the selection on the Images page, and selecting "Apply Changes", and went back to the listing page, and no error was shown.

This is likely due to the fact that the vivid image might not have any hwe kernels available, as it is the latest distro version released.

Related branches

summary: - When no HWE kernels for a release, MAAS UI shows
+ When no HWE kernels for a release, MAAS UI shows "string index out of
+ range"
Changed in maas:
milestone: none → 1.9.0
assignee: nobody → Lee Trager (ltrager)
Changed in maas:
status: New → Triaged
importance: Undecided → Critical
Lee Trager (ltrager) wrote :

I've been able to reproduce this with Wily, not Vivid. I was using lstrip to remove 'hwe-' which removes all characters given, unordered from a string. Switching to replace fixes the bug.

Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers