MaaS Install guide incorrectly refers to 12.04 cloud PPA

Bug #1481091 reported by Michael H Wilson on 2015-08-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Andres Rodriguez

Bug Description

See the small "Note" section under this subheading

http://maas.ubuntu.com/docs/install.html#installing-maas-from-the-archive

This is not correct for 14.04. Instead it should refer people to ppa:maas-maintainers/stable.

This error happens when you try to follow the documentation on 14.04:

root@ubuntu:~# add-apt-repository cloud-archive:tools
 Ubuntu Cloud Archive for cloud-tools (JuJu and MAAS)
 More info: https://wiki.ubuntu.com/ServerTeam/CloudArchive
Press [ENTER] to continue or ctrl-c to cancel adding it

Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 163, in <module>
    if not sp.add_source_from_shortcut(shortcut, options.enable_source):
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 727, in add_source_from_shortcut
    (deb_line, file) = shortcut.expand(codename=self.distro.codename)
  File "/usr/lib/python3/dist-packages/softwareproperties/cloudarchive.py", line 99, in expand
    if codename not in (MAP[self.caname]['release'],
KeyError: 'release'
root@ubuntu:~#

Changed in maas:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Andres Rodriguez (andreserl)
milestone: none → 1.9.0
Gavin Panella (allenap) on 2015-09-02
Changed in maas:
status: Confirmed → Triaged
Changed in maas:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers