[SRU] Can't set a list of forwarders (BIND config)

Bug #1470585 reported by Raphaël Badin on 2015-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Raphaël Badin
1.8
Critical
Raphaël Badin
maas (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
Vivid
Undecided
Unassigned
Wily
Undecided
Unassigned

Bug Description

The MAAS UI and the MAAS API only allow the user to pass a single address for the `forwarders` config. Note that the backend already support a space separated list of IPs.

[Impact]
This issue prevents users from adding multiple DNS resolvers in MAAS. With the fix, the user can add multiple DNS resolvers for MAAS to manage.

[Test Case]

Without the fix:
1. Install maas (sudo apt-get install maas)
2. Go to the Settings page on the Web UI
3. Go to the DNS settings and Add multiple DNS servers as forwarders
4. MAAS will fail to add multiple DNS servers as forwarders

With the fix:
1. Install maas (sudo apt-get install maas)
2. Go to the Settings page on the Web UI
3. Go to the DNS settings and Add multiple DNS servers as forwarders
4. MAAS will add multiple DNS servers as forwarders

[Regression Potential]
Minimal. This has been tested extensively in various environments, both on fresh installs and upgrades.

Related branches

Raphaël Badin (rvb) on 2015-07-01
Changed in maas:
importance: High → Critical
Mike Pontillo (mpontillo) wrote :

Note that the template on 1.7 looks like it only supports a single forwarder. It was fixed for 1.8 as a part of this merge:

https://code.launchpad.net/~allenap/maas/celery-in-dns-removal/+merge/241852

Raphaël Badin (rvb) on 2015-07-06
Changed in maas:
assignee: nobody → Raphaël Badin (rvb)
status: Triaged → Fix Committed
milestone: none → 1.9.0
summary: - Can't set a list of forwarders (BIND config)
+ [SRU] Can't set a list of forwarders (BIND config)
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.7.6+bzr3376-0ubuntu1

---------------
maas (1.7.6+bzr3376-0ubuntu1) wily; urgency=medium

  * New upstream release 1.7.6 bzr3376:
    - Accept list of forwarders for upstream_dns rather than just
      one. (LP: #1470585)
    - Fix upgrade issue where it would remove custom DNS config,
      potentially breaking DNS. (LP: #1413388)

  [ Raphaël Badin ]
  * Drop dependency on python-iscpy: the code has been integrated into
    MAAS. (LP: #1413388).

  [ Andres Rodriguez ]
  * Refactor maas-dns upgrade code so it doesn't break local DNS config
    and it gets migrated (LP: #1413388)

 -- Andres Rodriguez <email address hidden> Fri, 03 Jul 2015 00:11:50 -0400

Changed in maas (Ubuntu Wily):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.7.6+bzr3376-0ubuntu2~14.04.1

---------------
maas (1.7.6+bzr3376-0ubuntu2~14.04.1) trusty; urgency=medium

  * debian/control: Make maas-dns a Dependy of maas-region-controller.
  * debian/maas-region-controller.postinst: Ensure DNS config migration is
    always run. (LP: #1413388)

 -- Andres Rodriguez <email address hidden> Fri, 10 Jul 2015 13:47:40 -0400

Changed in maas (Ubuntu Trusty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.7.6+bzr3376-0ubuntu2~15.04.1

---------------
maas (1.7.6+bzr3376-0ubuntu2~15.04.1) vivid; urgency=medium

  * debian/control: Make maas-dns a Dependy of maas-region-controller.
  * debian/maas-region-controller.postinst: Ensure DNS config migration is
    always run. (LP: #1413388)

 -- Andres Rodriguez <email address hidden> Fri, 10 Jul 2015 13:47:40 -0400

Changed in maas (Ubuntu Vivid):
status: New → Fix Released
Changed in maas:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) on 2016-04-24
Changed in maas (Ubuntu Utopic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers