Internal server error saving the clusters interfaces

Bug #1446840 reported by Blake Rouse
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Unassigned

Bug Description

On a fresh package installation of trunk on trusty, a internal server error is raised when saving the clusters interface.

Seems to be related to permissions and bind.

2015-04-21 16:09:20 [HTTPChannel,0,127.0.0.1] 500 Error - /MAAS/clusters/cc3b1d99-6002-45bc-9132-320f66cf7c70/interfaces/eth0/edit/
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/twisted/web/wsgi.py", line 315, in run
     appIterator = self.application(self.environ, self.startResponse)
   File "/usr/lib/python2.7/dist-packages/django/core/handlers/wsgi.py", line 206, in __call__
     response = self.get_response(request)
   File "/usr/lib/python2.7/dist-packages/maasserver/utils/views.py", line 213, in get_response
     response = get_response(request)
   File "/usr/lib/python2.7/dist-packages/maasserver/utils/views.py", line 202, in get_response
     request, get_resolver(None), sys.exc_info())
 --- <exception caught here> ---
   File "/usr/lib/python2.7/dist-packages/maasserver/utils/views.py", line 187, in get_response
     return django_get_response(request)
   File "/usr/lib/python2.7/dist-packages/maasserver/utils/orm.py", line 331, in __exit__
     self.fire()
   File "/usr/lib/python2.7/dist-packages/provisioningserver/utils/twisted.py", line 151, in wrapper
     return func(*args, **kwargs)
   File "/usr/lib/python2.7/dist-packages/maasserver/utils/async.py", line 180, in fire
     self._fire_in_reactor(hook).wait()
   File "/usr/lib/python2.7/dist-packages/crochet/_eventloop.py", line 219, in wait
     result.raiseException()
   File "<string>", line 2, in raiseException

 exceptions.OSError: [Errno 1] Operation not permitted: '/etc/bind/maas/.named.conf.options.inside.maas.NfTF4f.tmp'

Related branches

Revision history for this message
Raphaël Badin (rvb) wrote :

This is apparently a regression caused by landing https://code.launchpad.net/~ubuntudotcom1/maas/bug-1443346-atomic-write-copy-ownership/+merge/255972.
CI has been failing since 3832. See http://162.213.35.104:8080/job/maas-utopic-trunk/318/artifact/results/artifacts/maas-logs/var/log/maas/regiond.log for details.
I've tried reverting this change and running the CI: works.

Revision history for this message
Raphaël Badin (rvb) wrote :

Here are the permissions you get when installing a package:

ls -l /etc/bind/maas
total 16
-rw-r--r-- 1 maas root 234 Apr 22 12:11 named.conf.maas
-rw-r--r-- 1 maas root 85 Apr 22 12:11 named.conf.options.inside.maas
-rw-r----- 1 maas bind 257 Apr 22 12:11 named.conf.rndc.maas
-rw------- 1 maas root 539 Apr 22 12:11 rndc.conf.maas

I'm guessing that the fact that the group is 'root' for named.conf.options.inside.maas is the source of the problem we're seeing.

Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers