Unable to determine purpose for node: node-08.maas when deploying multiple OS's

Bug #1445942 reported by Andres Rodriguez on 2015-04-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Blake Rouse
1.8
Critical
Blake Rouse

Bug Description

I was trying to deploy various OS at the same time, and the following error appeared:

==> /var/log/maas/regiond.log <==
2015-04-19 23:40:31 [maasserver] ERROR: Unable to determine purpose for node: 'node-08.maas'
2015-04-19 23:40:31 [-] Unhandled Error
        Traceback (most recent call last):
          File "/usr/lib/python2.7/threading.py", line 783, in __bootstrap
            self.__bootstrap_inner()
          File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
            self.run()
          File "/usr/lib/python2.7/threading.py", line 763, in run
            self.__target(*self.__args, **self.__kwargs)
        --- <exception caught here> ---
          File "/usr/lib/python2.7/dist-packages/twisted/python/threadpool.py", line 191, in _worker
            result = context.call(ctx, function, *args, **kwargs)
          File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 118, in callWithContext
            return self.currentContext().callWithContext(ctx, func, *args, **kw)
          File "/usr/lib/python2.7/dist-packages/twisted/python/context.py", line 81, in callWithContext
            return func(*args,**kw)
          File "/usr/lib/python2.7/dist-packages/provisioningserver/utils/twisted.py", line 151, in wrapper
            return func(*args, **kwargs)
          File "/usr/lib/python2.7/dist-packages/maasserver/utils/orm.py", line 404, in call_within_transaction
            return func_outside_txn(*args, **kwargs)
          File "/usr/lib/python2.7/dist-packages/maasserver/utils/orm.py", line 300, in retrier
            return func(*args, **kwargs)
          File "/usr/lib/python2.7/dist-packages/django/db/transaction.py", line 339, in inner
            return func(*args, **kwargs)
          File "/usr/lib/python2.7/dist-packages/maasserver/rpc/nodes.py", line 193, in request_node_info_by_mac_address
            return (node, node.get_boot_purpose())
          File "/usr/lib/python2.7/dist-packages/maasserver/models/node.py", line 1819, in get_boot_purpose
            preseed_type = get_deploying_preseed_type_for(self)
          File "/usr/lib/python2.7/dist-packages/maasserver/preseed.py", line 379, in get_deploying_preseed_type_for
            purpose = get_available_purpose_for_node(purpose_order, node)
          File "/usr/lib/python2.7/dist-packages/maasserver/preseed.py", line 348, in get_available_purpose_for_node
            "Unable to determine purpose for node: '%s'", node.fqdn)
        maasserver.exceptions.PreseedError: (u"Unable to determine purpose for node: '%s'", u'node-08.maas')

2015-04-19 23:40:31 [RegionServer,5,127.0.0.1] RegionServer connection lost (HOST:IPv4Address(TCP, '127.0.0.1', 44884) PEER:IPv4Address(TCP, '12
7.0.0.1', 57821))

==> /var/log/maas/clusterd.log <==
2015-04-19 23:40:31+0800 [ClusterClient,client] Unhandled error in Deferred:
2015-04-19 23:40:31+0800 [ClusterClient,client] Unhandled Error
        Traceback (most recent call last):
        Failure: twisted.protocols.amp.UnknownRemoteError: Code<UNKNOWN>: Unknown Error

Node08 was a windows deployment. However, when individually deploying just one system, this error was not present.

Related branches

Changed in maas:
milestone: none → 1.8.0
importance: Undecided → Critical
status: New → Confirmed
summary: - Unable to determine purpose for node: '%s'", u'node-08.maas'
+ Unable to determine purpose for node: node-08.maas when deploying
+ windows
summary: Unable to determine purpose for node: node-08.maas when deploying
- windows
+ multiple OS's
description: updated
Changed in maas:
status: Confirmed → Triaged
Changed in maas:
status: Triaged → Incomplete
Changed in maas:
assignee: nobody → Blake Rouse (blake-rouse)
Changed in maas:
milestone: 1.8.0 → 1.8.2
Blake Rouse (blake-rouse) wrote :

This issue is because of how operating systems that can have license keys is used. The ending '*' on the release value needs to be strip to set the correct distro_series.

Changed in maas:
status: Incomplete → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
milestone: 1.8.2 → 1.9.0
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers