Apache2 restart needed after upgrading to 1.8a9

Bug #1438782 reported by Adam Collard on 2015-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Andres Rodriguez

Bug Description

After upgrading from 1.7.1 to MAAS 1.8a9 (via experimental PPA) attempting to connect on port 80 (to Apache) led to 503s. Direct connections to :5420 worked as expected, and port 80 worked again after restarting apache2.

MAAS packages installed: http://paste.ubuntu.com/10713022/

APT stdout snippet

 * Restarting web server apache2
   ...done.
maas-regiond stop/waiting
maas-regiond start/running, process 19801
maas-clusterd stop/waiting
maas-clusterd start/running, process 19836
Setting up maas (1.8.0~alpha9+bzr3750-0ubuntu1~trusty1) ...

Note that apache2 is restarted before regiond/clusterd leading to the following apache error log: http://paste.ubuntu.com/10713046/

Related branches

Changed in maas:
milestone: none → 1.8.0
Changed in maas:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Andres Rodriguez (andreserl)
Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers