daily build of experimental PPA MAAS does not show enlisted node status on Web UI

Bug #1423457 reported by Taihsiang Ho on 2015-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Andres Rodriguez

Bug Description

tested with 14.04.1 server image by virt-manager

Steps to reproduce this bug:
1. install 14.04.1 server image by the selection "Multiple server install with MAAS"
2. after installation, add the ppa ppa:maas-maintainers/experimental,
update source list and then install the daily build of maas, maas-dns and maas-dhcp.
When asked, always choosing the maintainer's configuration.
3. create a maas superuser
4. using browser to log in the host controller[1]
5. import boot image
6. launch nodes by pxe boot. The nodes were boot by pxe and shutdown successfully.
7. back to the browser and check the enlisted node status[2]

Expected result:
[1] node status was shown. 0 node was attached to Networks.
[2] node status was shown. n nodes was attached to Networks. (n > 0)

Actual result:
[1] no node status was shown. 0 node was attached to Networks. Please refer to the attachment screenshot-maas-01.png
[2] no node status was shown. n nodes was attached to Networks. (n > 0) Please refer to attachment screenshot-maas-02-no-nodes.png

More information:
maas.log.tar.gz - log tar ball of /var/log/maas on host controller
dpkg-l.log - there is daily build version

ii maas 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server all-in-one metapackage
ii maas-cli 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS command line API tool
ii maas-cluster-controller 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server cluster controller
ii maas-common 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server common files
ii maas-dhcp 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS DHCP server
ii maas-dns 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS DNS server
ii maas-proxy 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS Caching Proxy
ii maas-region-controller 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server complete region controller
ii maas-region-controller-min 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS Server minimum region controller
ii python-django-maas 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server Django web framework
ii python-maas-client 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS python API client
ii python-maas-provisioningserver 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server provisioning libraries

maas-profilename-nodes-list.log - information dumped by the command "maas profile-name nodes list"

Please note the node status does not show on the web UI but it was shown by this command.

Related branches

Taihsiang Ho (taihsiangho) wrote :
Taihsiang Ho (taihsiangho) wrote :

maas-profilename-nodes-list.log - information dumped by the command "maas profile-name nodes list"

Taihsiang Ho (taihsiangho) wrote :

dpkg-l.log - there is daily build version

ii maas 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server all-in-one metapackage
ii maas-cli 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS command line API tool
ii maas-cluster-controller 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server cluster controller
ii maas-common 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server common files
ii maas-dhcp 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS DHCP server
ii maas-dns 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS DNS server
ii maas-proxy 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS Caching Proxy
ii maas-region-controller 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server complete region controller
ii maas-region-controller-min 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS Server minimum region controller
ii python-django-maas 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server Django web framework
ii python-maas-client 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS python API client
ii python-maas-provisioningserver 1.8.0~alpha1+bzr3523-0ubuntu1~trusty2 all MAAS server provisioning libraries

Taihsiang Ho (taihsiangho) wrote :
Taihsiang Ho (taihsiangho) wrote :
summary: - daily build maas does not show enlisted node status
+ daily build MAAS does not show enlisted node status on Web UI
summary: - daily build MAAS does not show enlisted node status on Web UI
+ daily build of experimental PPA MAAS does not show enlisted node status
+ on Web UI
Blake Rouse (blake-rouse) wrote :

This is because the packaging was missing the libjs-angularjs. I would not recommend using experimental, this is were the MAAS team does testing.

Stick with stable if you don't want issues like this to occur.

Thank you for the bug!

Changed in maas:
status: New → In Progress
status: In Progress → Fix Committed
importance: Undecided → High
assignee: nobody → Andres Rodriguez (andreserl)
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers