OS and Release no longer populate on Add Node page

Bug #1413030 reported by Newell Jensen on 2015-01-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Raphaël Badin

Bug Description

OS and Release are no longer populated on the Add Node page.

ubuntu@pops:~$ dpkg -l '*maas*'|cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-====================================-=====================================-============-===============================================================================
ii maas 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS server all-in-one metapackage
ii maas-cli 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS command line API tool
ii maas-cluster-controller 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS server cluster controller
ii maas-common 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS server common files
ii maas-dhcp 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS DHCP server
ii maas-dns 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS DNS server
ii maas-proxy 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS Caching Proxy
ii maas-region-controller 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS server complete region controller
ii maas-region-controller-min 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS Server minimum region controller
ii python-django-maas 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS server Django web framework
ii python-maas-client 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS python API client
ii python-maas-provisioningserver 1.8.0~alpha1+bzr3480-0ubuntu1 all MAAS server provisioning libraries

Related branches

Newell Jensen (newell-jensen) wrote :
Changed in maas:
importance: Undecided → Critical
status: New → Confirmed
milestone: none → 1.7.1
Newell Jensen (newell-jensen) wrote :
Download full text (76.5 KiB)

$ cat /var/log/maas/*

Jan 21 00:47:49 pops maas.cluster_upgrade: [INFO] Cluster upgrade hook make_maas_own_boot_resources started.
Jan 21 00:47:49 pops maas.cluster_upgrade: [INFO] Cluster upgrade hook make_maas_own_boot_resources finished.
Jan 21 00:47:49 pops maas.cluster_upgrade: [INFO] Cluster upgrade hook create_gnupg_home started.
Jan 21 00:47:49 pops maas.cluster_upgrade: [INFO] Cluster upgrade hook create_gnupg_home finished.
Jan 21 00:47:49 pops maas.cluster_upgrade: [INFO] Cluster upgrade hook retire_bootresources_yaml started.
Jan 21 00:47:49 pops maas.cluster_upgrade: [INFO] Cluster upgrade hook retire_bootresources_yaml finished.
Jan 21 00:47:49 pops maas.cluster_upgrade: [INFO] Cluster upgrade hook migrate_architectures_into_ubuntu_directory started.
Jan 21 00:47:49 pops maas.cluster_upgrade: [INFO] Cluster upgrade hook migrate_architectures_into_ubuntu_directory finished.
Jan 21 00:48:57 pops maas.lease_upload_service: [INFO] LeaseUploadService starting.
Jan 21 00:49:02 pops maas.import-images: [INFO] Started importing boot images.
Jan 21 00:49:02 pops maas.import-images: [WARNING] Finished importing boot images, the region does not have any boot images available.
Jan 21 00:49:02 pops maas.tftp: [WARNING] No boot images have been imported from the region.
Jan 21 00:50:57 pops maas.lease_upload_service: [INFO] Uploading 0 DHCP leases to region controller.
Jan 21 00:53:57 pops maas.import-images: [INFO] Started importing boot images.
Jan 21 00:53:57 pops maas.import-images: [WARNING] Finished importing boot images, the region does not have any boot images available.
Jan 21 00:53:57 pops maas.tftp: [WARNING] No boot images have been imported from the region.
2015-01-21 00:48:57+0000 [-] TFTP starting on 69
2015-01-21 00:48:57+0000 [-] Starting protocol <tftp.protocol.TFTP instance at 0x7f103ab8ae60>
2015-01-21 00:48:57+0000 [-] TFTP Listener started at 10.228.16.101:69
2015-01-21 00:48:57+0000 [-] TFTP starting on 69
2015-01-21 00:48:57+0000 [-] Starting protocol <tftp.protocol.TFTP instance at 0x7f103ab8afc8>
2015-01-21 00:48:57+0000 [-] TFTP Listener started at ::1:69
2015-01-21 00:48:57+0000 [-] TFTP starting on 69
2015-01-21 00:48:57+0000 [-] Starting protocol <tftp.protocol.TFTP instance at 0x7f103ab96d88>
2015-01-21 00:48:57+0000 [-] TFTP Listener started at 192.168.122.1:69
2015-01-21 00:48:57+0000 [-] TFTP starting on 69
2015-01-21 00:48:57+0000 [-] Starting protocol <tftp.protocol.TFTP instance at 0x7f103ab9e0e0>
2015-01-21 00:48:57+0000 [-] TFTP Listener started at 127.0.0.1:69
2015-01-21 00:48:57+0000 [Uninitialized] ClusterClient connection established (HOST:IPv4Address(TCP, '127.0.0.1', 54953) PEER:IPv4Address(TCP, u'127.0.0.1', 57974))
2015-01-21 00:48:57+0000 [ClusterClient,client] Event-loop 'pops:pid=107755' authenticated.
2015-01-21 00:48:59+0000 [Uninitialized] ClusterClient connection established (HOST:IPv4Address(TCP, '127.0.0.1', 54959) PEER:IPv4Address(TCP, u'127.0.0.1', 57974))
2015-01-21 00:48:59+0000 [ClusterClient,client] Event-loop 'pops:pid=107755' authenticated.
2015-01-21 00:49:00+0000 [ClusterClient,client] Cluster '44284e56-0bbb-4f3d-b2d9-e9bd2a3bc2d4' registered (via pops:pid=107755).
2015-01-21 ...

Andres Rodriguez (andreserl) wrote :

I confirm this to be the case in 1.7.1 and trunk. I have not seen this issue in 1.7.0

Raphaël Badin (rvb) wrote :

This was caused by revision 3270 on trunk (backported in 3300 on 1.7). This revision fixed: https://bugs.launchpad.net/maas/+bug/1378936. Since it doesn't really make sense to change the OS or the release before a node is allocated, the OS/release fields are hidden in this case (this is true when creating a node)… the only problem is that the labels for these two fields shouldn't be displayed at all.

Christian Reis (kiko) on 2015-01-22
Changed in maas:
status: Confirmed → Fix Committed
assignee: nobody → Raphaël Badin (rvb)
Changed in maas:
status: Fix Committed → Fix Released
Andres Rodriguez (andreserl) wrote :

This bug has been reported and fixed on upstream MAAS. However, provided that the bug was listed on the debian changelog, this appears as needing verification for pending SRU [1]. This bug did not affect current MAAS in Ubuntu, hence setting this to verification-done to unblock pending SRU.

[1]:http://people.canonical.com/~ubuntu-archive/pending-sru.html

tags: added: verification-done
tags: added: verification-needed
removed: verification-done
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers