can not enlist chassis with maas admin node-group probe-and-enlist-mscm

Bug #1403609 reported by Narinder Gupta on 2014-12-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Blake Rouse
1.7
Critical
Blake Rouse

Bug Description

trusty MAAS 1.7.1 in maas-maintainers ppa does not list the moonshot chassis nodes after running the following command:

sudo maas admin node-group probe-and-enlist-mscm $CLUSTER_UUID host=10.60.1.21 username=Administrator password=password

Reproduce the bugs:
step1: install MAAS from maas-maintainers PPA and configure it.
step2: import all the boot images
ste3: run command udo maas admin node-group probe-and-enlist-mscm $CLUSTER_UUID host=10.60.1.21 username=Administrator password=password

Results expected: All nodes in the chassis gets listed in the MAAS
Error: No node is listed and MAAS URL http://<maas ip>/MAAS is in accessible.

root@c60-vm:/var/log# dpkg --list | grep maas
ii maas 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS server all-in-one metapackage
ii maas-cli 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS command line API tool
ii maas-cluster-controller 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS server cluster controller
ii maas-common 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS server common files
ii maas-dhcp 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS DHCP server
ii maas-dns 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS DNS server
ii maas-proxy 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS Caching Proxy
ii maas-region-controller 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS server complete region controller
ii maas-region-controller-min 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS Server minimum region controller
ii python-django-maas 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS server Django web framework
ii python-maas-client 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS python API client
ii python-maas-provisioningserver 1.7.1~rc1+bzr3322-0ubuntu1~trusty1 all MAAS server provisioning libraries
root@c60-vm:/var/log#

hdl@c60-vm:~⟫ sudo maas admin node-group probe-and-enlist-mscm $CLUSTER_UUID host=10.60.1.21 username=Administrator password=password
Success.
Machine-readable output follows:

hdl@c60-vm:~⟫

But after that I can not access the MAAS page.
maas.log at http://paste.ubuntu.com/9544505/
maas-django.log http://paste.ubuntu.com/9544512/
apache2/access.log http://paste.ubuntu.com/9544537/
apache2/error.log http://paste.ubuntu.com/9544545/
pserv.log http://paste.ubuntu.com/9550469/

Related branches

Christian Reis (kiko) on 2014-12-17
Changed in maas:
assignee: nobody → Blake Rouse (blake-rouse)
assignee: Blake Rouse (blake-rouse) → nobody
Blake Rouse (blake-rouse) wrote :

The issue is that none of the probe-and-enlist functions are deferred to a thread, so it blocks the reactor from running. This causes the cluster from handling other messages and tftp requests.

Changed in maas:
status: New → In Progress
assignee: nobody → Blake Rouse (blake-rouse)
milestone: none → next
importance: Undecided → Critical
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
Andres Rodriguez (andreserl) wrote :

This bug has been reported and fixed on upstream MAAS. However, provided that the bug was listed on the debian changelog, this appears as needing verification for pending SRU [1]. This bug did not affect current MAAS in Ubuntu, hence setting this to verification-done to unblock pending SRU.

[1]:http://people.canonical.com/~ubuntu-archive/pending-sru.html

tags: added: verification-done
tags: added: verification-needed
removed: verification-done
tags: added: verification-done
removed: verification-needed
Changed in maas:
milestone: next → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers