TFTP into MAAS server to get pxelinux.0 causes unhandled error

Bug #1398159 reported by Andres Rodriguez on 2014-12-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Medium
Gavin Panella
1.7
Medium
Gavin Panella

Bug Description

I tried to manually connect to MAAS tftp server to obtain pxelinux.0 to verifyu that tftp was serving correctly, and I got the following unhandled error in pserv.log

2014-12-01 15:10:36-0500 [TFTP (UDP)] Datagram received from ('192.168.2.116', 43749): <RRQDatagram(filename=pxelinux.0, mode=netascii)>
2014-12-01 15:10:36-0500 [TFTP (UDP)] Datagram received from ('192.168.2.116', 43749): <RRQDatagram(filename=pxelinux.0, mode=netascii)>
2014-12-01 15:10:36-0500 [-] Unhandled error in Deferred:
2014-12-01 15:10:36-0500 [-] Unhandled Error
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 139, in maybeDeferred
     result = f(*args, **kw)
   File "/usr/lib/python2.7/dist-packages/provisioningserver/boot/windows.py", line 203, in get_node_info
     return request_node_info_by_mac_address(remote_mac)
   File "/usr/lib/python2.7/dist-packages/provisioningserver/utils/twisted.py", line 102, in wrapper
     return func(*args, **kwargs)
   File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 1237, in unwindGenerator
     return _inlineCallbacks(None, gen, Deferred())
 --- <exception caught here> ---
   File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 1099, in _inlineCallbacks
     result = g.send(result)
   File "/usr/lib/python2.7/dist-packages/provisioningserver/boot/windows.py", line 102, in request_node_info_by_mac_address
     RequestNodeInfoByMACAddress, mac_address=mac_address)
   File "/usr/lib/python2.7/dist-packages/provisioningserver/utils/twisted.py", line 102, in wrapper
     return func(*args, **kwargs)
   File "/usr/lib/python2.7/dist-packages/provisioningserver/rpc/common.py", line 125, in __call__
     return self._conn.callRemote(cmd, **kwargs)
   File "/usr/lib/python2.7/dist-packages/twisted/protocols/amp.py", line 821, in callRemote
     return co._doCommand(self)
   File "/usr/lib/python2.7/dist-packages/twisted/protocols/amp.py", line 1777, in _doCommand
     self.makeArguments(self.structured, proto),
   File "/usr/lib/python2.7/dist-packages/twisted/protocols/amp.py", line 1686, in makeArguments
     proto)
   File "/usr/lib/python2.7/dist-packages/twisted/protocols/amp.py", line 2535, in _objectsToStrings
     argparser.toBox(argname, strings, myObjects, proto)
   File "/usr/lib/python2.7/dist-packages/twisted/protocols/amp.py", line 1237, in toBox
     strings[name] = self.toStringProto(obj, proto)
   File "/usr/lib/python2.7/dist-packages/twisted/protocols/amp.py", line 1263, in toStringProto
     return self.toString(inObject)
   File "/usr/lib/python2.7/dist-packages/twisted/protocols/amp.py", line 1353, in toString
     return String.toString(self, inObject.encode('utf-8'))
 exceptions.AttributeError: 'NoneType' object has no attribute 'encode'

i connected with:

tftp
tftp> connect
(to) 192.168.2.116
tftp> get pxelinux.0
Transfer timed out.

Related branches

Changed in maas:
milestone: none → 1.7.1
Christian Reis (kiko) wrote :

Is this a dupe of bug 1246236?

Christian Reis (kiko) on 2014-12-03
Changed in maas:
milestone: 1.7.1 → next
Changed in maas:
milestone: next → 1.7.1
tags: added: solutions
Changed in maas:
importance: Undecided → Medium
status: New → Triaged
Blake Rouse (blake-rouse) wrote :

I believe this is because you are accessing the TFTP server from the same machine that the TFTP server is running. That is causing the issue as your local machine will not be in the arp cache.

I believe this is the issue because I have came a crossed it before, and this was the issue.

Gavin Panella (allenap) on 2014-12-08
Changed in maas:
assignee: nobody → Gavin Panella (allenap)
status: Triaged → In Progress
Gavin Panella (allenap) on 2014-12-10
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
Christian Reis (kiko) on 2015-01-28
Changed in maas:
status: Fix Released → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released

Hello Andres, or anyone else affected,

Accepted maas into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

This issue has been verified to work both on upgrade and fresh install, and has been QA'd. Marking verification-done.

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers