AMT Node with Disk Erasing Option Enabled is not restarted

Bug #1397567 reported by Andres Rodriguez on 2014-11-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Raphaël Badin
1.7
Critical
Raphaël Badin
Trunk
Critical
Raphaël Badin

Bug Description

WIth the Disk Erase option enabled on the WebUI, I tried to 'Release' a node that was on and deployed. When I release the Node, MAAS, instead of powering the node off and then on to start the disk erasing, it tries to power on the node, when it is already on.

This causes that the node is never rebooted to perform the disk erasing.

INFO 0 minutes ago Powering node on
INFO 0 minutes ago Node changed status — From 'Deployed' to 'Disk erasing'
INFO 1 minute ago Node changed status — From 'Deploying' to 'Deployed'
INFO 1 minute ago PXE Request — local boot
INFO 1 minute ago PXE Request — local boot

I have to manually reboot the deployed node in order for it to enter the disk erasing mode

Related branches

description: updated
Changed in maas:
assignee: nobody → Jason Hobbs (jason-hobbs)
Changed in maas:
milestone: none → 1.7.1
Raphaël Badin (rvb) wrote :

I'm seeing this too on the current 1.7 branch.

Changed in maas:
status: New → Triaged
importance: Undecided → Critical
Jason Hobbs (jason-hobbs) wrote :

I just tested this and it worked fine with 1.7.1+bzr3373-0ubuntu1.

What exact version are you using? What type of power control is used?

Jason Hobbs (jason-hobbs) wrote :

I tested with 1.7.1~rc1+bzr3307-0ubuntu1~trusty1, from the experimental ppa, and still can't reproduce this. It works fine for me.

Jason Hobbs (jason-hobbs) wrote :

Marked as incomplete until someone can provide information how to reproduce this, or what kind of system it occurred on, with some helpful logs.

Raphaël Badin (rvb) wrote :

I was able to reproduce this bug with 1.7.1~rc5+bzr3341-0ubuntu1: http://paste.ubuntu.com/9933135/. It looks as if the node didn't get powered off at all when I released it. This happened with an AMT box.

Looking at the code, I don't see why the node would be powered off at all when releasing with the 'enable_disk_erasing_on_release' config: it will go through models/node.py:release_or_erase and then models/node.py:start_disk_erasing and start_disk_erasing will simply try to power on the node (without powering it off first). I must be missing something.

I can also reproduce this with 1.7.1~rc5+bzr3341-0ubuntu1 on Trusty, with a pair of Intel NUCs.

summary: - Node with Disk Erasing Option Enabled is not restart
+ Node with Disk Erasing Option Enabled is not restarted
Raphaël Badin (rvb) wrote :

I can't reproduce this with an IPMI box, only with an AMT box.

summary: - Node with Disk Erasing Option Enabled is not restarted
+ AMT Node with Disk Erasing Option Enabled is not restarted
Christian Reis (kiko) wrote :

Is there a CI task to ensure this remains fixed?

Hello Andres, or anyone else affected,

Accepted maas into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

This issue has been verified to work both on upgrade and fresh install, and has been QA'd. Marking verification-done.

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers