Removing managed interface causes maas to delete nodes

Bug #1396308 reported by Jill Rouleau on 2014-11-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Graham Binns

Bug Description

In maas 1.7 (1.7.0+bzr3299-0ubuntu1~trusty), removing the managed interface associated with the pxe network causes maas to delete all nodes without warning.

While testing changes on a maas network that had several nodes deployed, removed the interface that is on the pxe network. All nodes were unexpectedly deleted and had to be added back in after reconfiguring interface. Tested this same action on another maas network running 1.5+bzr2252-0ubuntu1 and associated nodes were unaffected.

Related branches

Jill Rouleau (jillrouleau) wrote :
Gavin Panella (allenap) on 2014-11-25
Changed in maas:
status: New → Triaged
importance: Undecided → Critical
Graham Binns (gmb) wrote :

Confirmed this morning on my test maas; this is probably due to Django's defaulting to ON DELETE CASCADE.

Changed in maas:
assignee: nobody → Graham Binns (gmb)
milestone: none → 1.7.1
Graham Binns (gmb) on 2014-11-26
Changed in maas:
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released

Hello Jill, or anyone else affected,

Accepted maas into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

This issue has been verified to work both on upgrade and fresh install, and has been QA'd. Marking verification-done.

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments