PowerKVM / VIrsh import should allow you to specify a prefix to filter VM's to import

Bug #1393423 reported by Andres Rodriguez on 2014-11-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Newell Jensen

Bug Description

PowerKVM / Virsh should allow you to import a set of VM's from a physical host based on a prefix. This is to ensure that it only imports a few VM's and not all of the VM's within a physical host:

By default it should improt ALL of the VM's.
If specified, it should import those based on a prefix:
 --import-prefix

or something along those lines.

Related branches

Changed in maas:
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Newell Jensen (newell-jensen)
milestone: none → 1.7.1
Graham Binns (gmb) wrote :

Not a crash or dataloss so re-triaging to high; removed Newell as assignee as he's moving to Hyperscale.

Changed in maas:
assignee: Newell Jensen (newell-jensen) → nobody
status: Confirmed → Triaged
importance: Critical → High
Newell Jensen (newell-jensen) wrote :

Setting myself back to assignee since I already have a branch for this.

Changed in maas:
assignee: nobody → Newell Jensen (newell-jensen)
tags: added: server-hwe
Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released

Hello Andres, or anyone else affected,

Accepted maas into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

This issue has been verified to work both on upgrade and fresh install, and has been QA'd. Marking verification-done.

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers