MAAS pie chart doesn't break down state

Bug #1390434 reported by Adam Collard on 2014-11-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
MAAS
Critical
Raphaël Badin

Bug Description

The pie chart on the front page of MAAS isn't behaving as it once did. I noticed it on RC2 but I can't say for sure when it was introduced.

The behaviour I expect is that when I hover over different coloured segments of the pie chart, I get the text on the right hand side telling me what the colour means (e.g. Deployed, Commissioned) and how many nodes are in that state.

What I am seeing instead is the same message "12 nodes in this MAAS" wherever I hover the cursor. Note that it does flicker between them suggesting that there should be a different message.

Related branches

Christian Reis (kiko) on 2014-11-07
Changed in maas:
milestone: none → 1.7.0
importance: Undecided → Critical
Jason Hobbs (jason-hobbs) wrote :

This happens on my MAAS too.

Changed in maas:
status: New → Triaged
Blake Rouse (blake-rouse) wrote :

What browser are you using?

Adam Collard (adam-collard) wrote :

Tried in both Firefox and Chromium. Same deal, there are no errors in the console.

Raphaël Badin (rvb) on 2014-11-07
Changed in maas:
assignee: nobody → Raphaël Badin (rvb)
status: Triaged → In Progress
Raphaël Badin (rvb) on 2014-11-07
Changed in maas:
status: In Progress → Fix Committed
Jason Hobbs (jason-hobbs) wrote :

I'm testing with 1.7.0~rc3+bzr3299-0ubuntu1~trusty1 and my chart still shows all nodes as offline when they are commissioning.

Changed in maas:
status: Fix Committed → In Progress
Raphaël Badin (rvb) wrote :

> I'm testing with 1.7.0~rc3+bzr3299-0ubuntu1~trusty1 and my chart still shows all nodes as offline when they are commissioning.

This, I think, is another bug. Can you please file it as such? (This bug was about broken Javascript code, and it seems to me that what you're reporting here is more of a "semantic" bug where commissioning nodes are reported as "offline").

Changed in maas:
status: In Progress → Fix Committed
Jason Hobbs (jason-hobbs) wrote :

Yes, I had it marked as another bug which you marked as a duplicate of this bug. Bug #1391612. I'll reopen that one.

Changed in maas:
status: Fix Committed → Fix Released

Hello Adam, or anyone else affected,

Accepted maas into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

This issue has been verified to work both on upgrade and fresh install, and has been QA'd. Marking verification-done.

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers