X64 HP Moonshot M300 Cartridges change their power type and power address after commissioning on Maas 1.7 Beta6

Bug #1382075 reported by Sean Feole on 2014-10-16
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Newell Jensen
1.7
Undecided
Newell Jensen

Bug Description

This bug was found after commissioning the HP Proliant M300 Cartridge in bug, https://bugs.launchpad.net/maas/+bug/1377969

After Commissioning the m300 node, a user will be unable to start it due to a message:

"Failed to power on node — Node could not be powered on: moonshot failed with return code 127: /bin/sh: 42: /usr/bin/ipmitool: not found Got unknown power state from ipmipower: '' /bin/sh: 42: /usr/bin/ipmitool: not found"

After investigating, the power type and power address on the node actually changed after commissioning phase

The Power Type will change from:
"Moonshot HP ILO Chassis Manager" to "ILO4 Moonshot Chassis"

The Power Address also will change from:
"c5n1" to " -B 0 -T 0x8a -b 7 -t 0x72 -m 0x20 "

Moving the Power Type and Power Address back to its original values and saving appears to be the temporary workaround as I'm now able to use the M300 Cartridge in MAAS successfully. I believe this may be a regression from a previous version of Maas.

Related branches

Sean Feole (sfeole) wrote :

ubuntu@ubuntu:~$ apt-cache policy maas
maas:
  Installed: 1.7.0~beta6+bzr3246-0ubuntu1~trusty1
  Candidate: 1.7.0~beta6+bzr3260-0ubuntu1~trusty1

tags: added: hs-arm64
summary: - X64 HP Moonshot Avoton Cartridges change their power type and power
+ X64 HP Moonshot M300 Cartridges change their power type and power
address after commissioning on Maas 1.7 Beta6
tags: added: hs-moonshot
tags: added: hs-moonshot-maas-juju
removed: hs-moonshot
Christian Reis (kiko) wrote :

If this is true then the ipmitool probing of the IPMI details during enlistment/commissioning is broken. Did this work with 1.5 or 1.6? Did we change this in 1.7?

Changed in maas:
milestone: none → 1.7.0
importance: Undecided → High
Graham Binns (gmb) on 2014-10-20
Changed in maas:
assignee: nobody → Graham Binns (gmb)
Andres Rodriguez (andreserl) wrote :

This seems to be like ipmitool is not installed. Can you install ipmitool and test again?

Graham Binns (gmb) wrote :

Marking this incomplete until we know about the results of installing ipmitool on the cluster.

Changed in maas:
status: New → Incomplete
assignee: Graham Binns (gmb) → nobody
Changed in maas:
assignee: nobody → Newell Jensen (newell-jensen)
Sean Feole (sfeole) wrote :

Spoke with Newell last night, he made some positive progress on this bug. I'll let him make an update with his status

Andrew Cloke (andrew-cloke) wrote :

Marking as "in progress" as Newell is making progress.

Changed in maas:
status: Incomplete → In Progress
Christian Reis (kiko) on 2014-10-27
Changed in maas:
status: In Progress → Fix Committed
Christian Reis (kiko) on 2014-10-30
Changed in maas:
status: Fix Committed → Triaged
milestone: 1.7.0 → 1.7.1
Changed in maas:
assignee: Newell Jensen (newell-jensen) → nobody
Christian Reis (kiko) wrote :

I've filed bug 1389808 to change the commissioning semantics. If we agree that's the way forward then we can close the trunk task of this bug off.

Changed in maas:
assignee: nobody → Newell Jensen (newell-jensen)
status: Triaged → In Progress
tags: added: hs-arm64-maas-juju
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
milestone: 1.7.1 → none

Hello Sean, or anyone else affected,

Accepted maas into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/maas/1.7.5+bzr3369-0ubuntu1~14.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

This issue has been verified to work both on upgrade and fresh install, and has been QA'd. Marking verification-done.

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers