Can't search node by names

Bug #1359365 reported by Andres Rodriguez on 2014-08-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
High
Julian Edwards

Bug Description

Can't search node by hostnames in the webui.

Related branches

tags: added: oil usability
Raphaël Badin (rvb) wrote :

In the search box, you can use 'maas-name=<hostname>'.

Changed in maas:
status: New → Incomplete

Thanks not very user friendly... It should be set like that by default.....
It defaults to tag.
On Aug 20, 2014 6:25 PM, "Raphaël Badin" <email address hidden> wrote:

> In the search box, you can use 'maas-name=<hostname>'.
>
> ** Changed in: maas
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1359365
>
> Title:
> Can't search node by names
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/maas/+bug/1359365/+subscriptions
>

Julian Edwards (julian-edwards) wrote :

Right, this is terrible usability.

Changed in maas:
status: Incomplete → Triaged
importance: Undecided → High
Changed in maas:
milestone: none → 1.7.0
Raphaël Badin (rvb) wrote :

I agree that the search box is not really usable the way it works now. It was designed to let a user use a "constraints string" that matches what you would pass to Juju. If we're moving away from this (and I think we should) we need to design what we want instead.

Christian Reis (kiko) on 2014-10-02
Changed in maas:
milestone: 1.7.0 → next
Changed in maas:
assignee: nobody → Julian Edwards (julian-edwards)
status: Triaged → In Progress
Changed in maas:
status: In Progress → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
Changed in maas:
milestone: next → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers