[SRU] "ImportError: No module named pexpect" when setting up maas-region-controller

Bug #1352273 reported by Haw Loeung on 2014-08-04
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned
maas (Ubuntu)
Critical
Greg Lutostanski
Trusty
Critical
Greg Lutostanski

Bug Description

[Impact]
 * Install required deps for maas-provisioningserver (move from maas-region-controller) so it installs in correct order.

[Testcase]
 * Install python-maas-provisioningserver without error (will throw No module named pexpect if not including fix)

[Regression Potential]
 * Almost none

Hi,

We're upgrading our MAAS infrastructure from precise+MAAS 1.4 to trusty+MAAS 1.5. During a do-release-upgrade, we're seeing the following traceback when setting up maas-region-controller:

 in load_app
    models = import_module('%s.models' % app_name)
  File "/usr/lib/python2.7/dist-packages/django/utils/importlib.py", line 40, in import_module
    __import__(name)
  File "/usr/lib/python2.7/dist-packages/maasserver/models/__init__.py", line 44, in <module>
    from maasserver.models.bootimage import BootImage
  File "/usr/lib/python2.7/dist-packages/maasserver/models/bootimage.py", line 26, in <module>
    from maasserver.models.nodegroup import NodeGroup
  File "/usr/lib/python2.7/dist-packages/maasserver/models/nodegroup.py", line 35, in <module>
    from maasserver.refresh_worker import refresh_worker
  File "/usr/lib/python2.7/dist-packages/maasserver/refresh_worker.py", line 21, in <module>
    from provisioningserver.tasks import refresh_secrets
  File "/usr/lib/python2.7/dist-packages/provisioningserver/tasks.py", line 49, in <module>
    from provisioningserver.custom_hardware.virsh import probe_virsh_and_enlist
  File "/usr/lib/python2.7/dist-packages/provisioningserver/custom_hardware/virsh.py", line 18, in <module>
    import pexpect
ImportError: No module named pexpect

The python-pexpect package isn't installed because we have "APT::Install-Recommends" set to "false".

iF maas-region-controller 1.5.2+bzr2282-0ubuntu0.2 all MAAS server complete region controller
ii maas-region-controller-min 1.5.2+bzr2282-0ubuntu0.2 all MAAS Server minimum region controller

Regards,

Haw

Related branches

Changed in maas:
status: New → Invalid
Greg Lutostanski (lutostag) wrote :

The python-pexpect dependency needs to be moved to python-maas-provisioningserver so it works for both the cluster and region controllers.

Changed in maas (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Greg Lutostanski (lutostag)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.6.1+bzr2550-0ubuntu1

---------------
maas (1.6.1+bzr2550-0ubuntu1) utopic; urgency=medium

  * New upstream bugfix release:
    - Auto-link node MACs to Networks (LP: #1341619)

  [ Julian Edwards ]
  * debian/maas-region-controller.postinst: Don't restart RabbitMQ on
    upgrades, just ensure it's running. Should prevent a race with the
    cluster celery restarting.
  * debian/rules: Pull upstream branch from the right place.

  [ Andres Rodriguez ]
  * debian/maas-region-controller.postinst: Ensure cluster celery is
    started if it also runs on the region.
 -- Julian Edwards <email address hidden> Thu, 21 Aug 2014 18:38:27 +1000

Changed in maas (Ubuntu):
status: Confirmed → Fix Released
summary: - "ImportError: No module named pexpect" when setting up maas-region-
- controller
+ [SRU] "ImportError: No module named pexpect" when setting up maas-
+ region-controller
description: updated
Changed in maas (Ubuntu Trusty):
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Greg Lutostanski (lutostag)
milestone: none → trusty-updates

Hello Haw, or anyone else affected,

Accepted maas into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/maas/1.5.4+bzr2294-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

Tested and the issue is fixed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.5.4+bzr2294-0ubuntu1.1

---------------
maas (1.5.4+bzr2294-0ubuntu1.1) trusty-proposed; urgency=medium

  * Add hardware enablement for armhf/keystone (LP: #1350103)
 -- Greg Lutostanski <email address hidden> Thu, 18 Sep 2014 16:43:56 -0500

Changed in maas (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers