Twisted reactors not given chance to shut down properly in mod_wsgi

Bug #1350786 reported by Gavin Panella
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MAAS
High
Gavin Panella

Bug Description

The symptom is that stale records are being left behind in the `eventloops` table, pointing to defunct event-loops. These are cleared up once they're 5 minutes old, but in the meantime there are alarming log messages. MAAS may be operating correctly but it's hard to see between these log messages.

Two things we could do:
- Quieten the log messages.
- Investigate ways of getting mod_wsgi to gracefully shutdown Python processes (or discover if there's a different root cause).

Tags: rpc Edit Tag help

Related branches

Changed in maas:
assignee: nobody → Gavin Panella (allenap)
Changed in maas:
milestone: none → 1.6.1
Changed in maas:
milestone: 1.7.0 → next
Christian Reis (kiko)
Changed in maas:
milestone: next → 1.7.1
Revision history for this message
Andres Rodriguez (andreserl) wrote :

Ok, I just came across this one in OIL.

This is really frustrating error messaging that should not be present in the 1.7.0. This leads people to believe that something very wrong is happening, when it might not be the case, and this is critical enough to be released as part of 1.7.0.

2014-11-03 09:12:24+0000 [Uninitialized] Event-loop maas-trusty-back-may22:pid=2897 (127.0.0.1:55147): Connection was refused by other side: 111: Connection refused.

Gavin Panella (allenap)
Changed in maas:
status: Triaged → In Progress
Changed in maas:
milestone: 1.7.1 → 1.7.2
Gavin Panella (allenap)
Changed in maas:
status: In Progress → Fix Committed
Christian Reis (kiko)
Changed in maas:
milestone: 1.7.2 → next
Changed in maas:
status: Fix Committed → Fix Released
milestone: next → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers