[SRU] pserv dies after upgrade to beta5~ppa1 (release cut for the boot images fix)

Bug #1342302 reported by Andres Rodriguez on 2014-07-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
Critical
Gavin Panella
maas (Ubuntu)
Undecided
Unassigned
Trusty
Critical
Greg Lutostanski

Bug Description

[Impact]
 * Allow usage of pserv for maas cluster controller on 1pv6 addresses

[Testcase]
 * Install maas-cluster controller and make sure it is authbind is allowed to listen on the ipv6 address (check /etc/authbind/byuid/*)

[Regression Potential]
 * Minimal

After upgrade from beta4 to beta5~ppa1, pserv dies with the following:

2014-07-15 14:26:53-0400 [-] TFTP Listener started at 10.14.4.1:69
2014-07-15 14:26:53-0400 [-] TFTP Listener started at 10.14.4.1:69
2014-07-15 14:26:53-0400 [-] Unhandled Error
 Traceback (most recent call last):
   File "/usr/lib/python2.7/dist-packages/twisted/application/service.py", line 282, in startService
     service.startService()
   File "/usr/lib/python2.7/dist-packages/twisted/application/internet.py", line 273, in startService
     self._loopFinished = self._loop.start(self.step, now=True)
   File "/usr/lib/python2.7/dist-packages/twisted/internet/task.py", line 173, in start
     self()
   File "/usr/lib/python2.7/dist-packages/twisted/internet/task.py", line 218, in __call__
     d = defer.maybeDeferred(self.f, *self.a, **self.kw)
 --- <exception caught here> ---
   File "/usr/lib/python2.7/dist-packages/twisted/internet/defer.py", line 139, in maybeDeferred
     result = f(*args, **kw)
   File "/usr/lib/python2.7/dist-packages/provisioningserver/tftp.py", line 297, in updateServers
     tftp_service.setServiceParent(self)
   File "/usr/lib/python2.7/dist-packages/twisted/application/service.py", line 186, in setServiceParent
     self.parent.addService(self)
   File "/usr/lib/python2.7/dist-packages/twisted/application/service.py", line 308, in addService
     service.privilegedStartService()
   File "/usr/lib/python2.7/dist-packages/twisted/application/internet.py", line 105, in privilegedStartService
     self._port = self._getPort()
   File "/usr/lib/python2.7/dist-packages/provisioningserver/tftp.py", line 221, in _getPort
     return self._listenUDP(*self.args, **self.kwargs)
   File "/usr/lib/python2.7/dist-packages/provisioningserver/tftp.py", line 227, in _listenUDP
     p.startListening()
   File "/usr/lib/python2.7/dist-packages/twisted/internet/udp.py", line 171, in startListening
     self._bindSocket()
   File "/usr/lib/python2.7/dist-packages/twisted/internet/udp.py", line 191, in _bindSocket
     raise error.CannotListenError(self.interface, self.port, le)
 twisted.internet.error.CannotListenError: Couldn't listen on ::1:69: [Errno 2] No such file or directory.

2014-07-15 14:26:53-0400 [-] Warning: No permission to delete pid file
2014-07-15 14:26:53-0400 [-] Warning: No permission to delete pid file

Related branches

Changed in maas:
importance: Undecided → Critical
description: updated
Gavin Panella (allenap) wrote :

I think this is because lp:~maas-maintainers/maas/packaging.trusty is
missing r285 from lp:~maas-maintainers/maas/packaging:

  285 Gavin Panella 2014-06-27 [merge]
      [r=blake-rouse][bug=][author=allenap] Configure authbind to permit
      binding all IPv6 addresses on ports 68 and 69 too.

Gavin Panella (allenap) wrote :

If that is the cause, then I'm surprised it's just cropped up. Have the 1.6 packages been built using the trunk packaging branch before now?

Changed in maas:
status: New → In Progress
assignee: nobody → Gavin Panella (allenap)
Gavin Panella (allenap) on 2014-07-15
Changed in maas:
status: In Progress → Fix Committed

On Tuesday 15 Jul 2014 21:26:19 you wrote:
> If that is the cause, then I'm surprised it's just cropped up. Have the
> 1.6 packages been built using the trunk packaging branch before now?

Yes.

Changed in maas:
status: Fix Committed → Fix Released
description: updated
summary: - pserv dies after upgrade to beta5~ppa1 (release cut for the boot images
- fix)
+ [SRU] pserv dies after upgrade to beta5~ppa1 (release cut for the boot
+ images fix)
Chris J Arges (arges) on 2014-09-02
Changed in maas (Ubuntu):
status: New → Fix Released
Changed in maas (Ubuntu Trusty):
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Greg Lutostanski (lutostag)
milestone: none → trusty-updates

Hello Andres, or anyone else affected,

Accepted maas into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/maas/1.5.4+bzr2294-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Andres Rodriguez (andreserl) wrote :

It has been tested and the issue is fixed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package maas - 1.5.4+bzr2294-0ubuntu1.1

---------------
maas (1.5.4+bzr2294-0ubuntu1.1) trusty-proposed; urgency=medium

  * Add hardware enablement for armhf/keystone (LP: #1350103)
 -- Greg Lutostanski <email address hidden> Thu, 18 Sep 2014 16:43:56 -0500

Changed in maas (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers