Changing the config item 'commissioning_distro_series' fails with an incomprehensible validation error

Bug #1304408 reported by Raphaël Badin on 2014-04-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Raphaël Badin
1.5
High
Raphaël Badin

Bug Description

When changing the config item 'commissioning_distro_series' to 'precise', I get the following validation error:
    ValidationError: {u'commissioning_distro_series': [u"'precise' is not a valid distro_series. It should be one of: '', 'precise', 'quantal', 'raring', 'saucy', 'trusty'."]}
It's incomprehensible because 'precise' is among the listed valid series.

Full stack trace: http://paste.ubuntu.com/7221515/

Related branches

Raphaël Badin (rvb) on 2014-04-08
description: updated
Raphaël Badin (rvb) on 2014-04-09
Changed in maas:
status: Triaged → Fix Committed
assignee: nobody → Raphaël Badin (rvb)
Changed in maas:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers