The cluster listing page isn't paginated

Bug #1301242 reported by Raphaël Badin on 2014-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MAAS
High
Raphaël Badin
1.5
High
Raphaël Badin

Bug Description

When a MAAS instance has a lot of clusters, the cluster listing page becomes huge, up to the point where it is intractable, because it's not paginated. The problem is made worse by the fact that the cluster listing is on the settings page: with many clusters the settings page is slow and thus access to the other settings is difficult.

Related branches

tags: added: hyperscale
removed: hypercale
Raphaël Badin (rvb) on 2014-04-03
Changed in maas:
milestone: none → 14.10
assignee: nobody → Raphaël Badin (rvb)
Raphaël Badin (rvb) on 2014-04-03
Changed in maas:
status: Triaged → Fix Committed
Changed in maas:
status: Fix Committed → Fix Released
milestone: 14.10 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers